ANSI escapes are showing up in TreeHerder logs

RESOLVED DUPLICATE of bug 1150362

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1150362
3 years ago
3 years ago

People

(Reporter: kats, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Not sure if this is the right component, please move as needed.

See for example https://treeherder.mozilla.org/logviewer.html#?job_id=6589442&repo=try - the timestamp at the start of the line is swaddled in ANSI escape sequences, which is fine if the output is directed to a console but probably shouldn't be happening when logging to a file. This seems like a recent regression as I don't recall seeing this before.
See Also: → bug 1150362
It looks like this is specific to taskcluster, and the logging format on that hasn't been fully settled yet: https://bugzilla.mozilla.org/show_bug.cgi?id=1150362

Want to reso:duplicate this one and continue the discussion there?
Sounds good to me.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150362
You need to log in before you can comment on or make changes to this bug.