Closed Bug 11550 Opened 21 years ago Closed 20 years ago

Alt-F not working on linux

Categories

(Core :: XUL, defect, P3)

Other
Linux
defect

Tracking

()

VERIFIED INVALID

People

(Reporter: sujay, Assigned: hyatt)

References

Details

(Keywords: platform-parity, Whiteboard: Need a decision to be made here.)

using 8/10 build of apprunner

1) launch apprunner
2) launch editor
3) use Ctrl-F to bring up Find dialog

it doesn't work, it doesn't seem wired up.

all platforms.
Assignee: buster → brade
reassign to myself
Status: NEW → ASSIGNED
this works fine on Macintosh; do you see the shortcut listed in the menu?
yeah buts its listed as Ctrl-Shift-Alt-F

and when using this sequence, it still doesn't bring up the Find dialog.
Does Ctrl-F work?
Is this bug really that Ctrl-Shift-Alt-F shows up in the menu when it shouldn't?

What shows up in the menus on Linux?
Mac shows just "F"
Ctrl-F doesn't work and also Ctrl-Shift-Alt-F shouldn't be
showing up oin the menu unless it was intended to.
does Ctrl-Alt-Shift-F show up in the menu only on Windows or both Windows and
Linux?  That should probably be filed as a separate bug since it sounds like a
widget problem.
Assignee: brade → saari
Status: ASSIGNED → NEW
Component: Editor → XP Toolkit/Widgets
Summary: Ctrl-F not wired for Find → Ctrl-F shows up as Ctrl-Alt-Shift-F in editor menu
Changing summary for this bug to reflect only the menu problem.
The keybinding itself not working is bug #11568.
Reassigning this bug to saari@netscape.com and changing to XP Toolkit component.

(Note that on Macintosh, the clover-leaf symbol for Command is missing from the
menu and Alt and Shift do not show up)

This may be a bug in xpmenus.  cc'ing hyatt@netscape.com
Fixed the clover leaf problem on Mac. Not sure about the problems on the other
platforms, as it is an XPMenu issue.
Status: NEW → ASSIGNED
Target Milestone: M10
Blocks: 12670
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
This appears to be working now on Windows, and it should be working on linux
too in that case. Marking works for me.
Status: RESOLVED → REOPENED
Summary: Ctrl-F shows up as Ctrl-Alt-Shift-F in editor menu → [PP]Alt-F not working on linux
OS: All → Linux
Hardware: All → Other
not working on Linux...in 9/9 build.
chaning platform+OS to Linux only.
Resolution: WORKSFORME → ---
Clearing WORKSFORME resolution due to reopen.
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Actually, this does should on Linux, but the correct modifier key is not Alt but
Control (as the initial steps above indicate).  Sujay, could you please retest?
Status: RESOLVED → REOPENED
still not working in 9/15 build.
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
Target Milestone: M10 → M12
moving to m12
sujay--I think Chris Saari got keybindings working again.  Can you retest when
you have a chance?  Thanks!
mass-moving all m12 bugs to m13
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Marking fixed to get someone to look at this and close it.
not working still in 12/17 build.

Alt-F brings up the file menu, not the Find dialog...

Pull down EDit menu and you'll see the Find keyboard shortcut which is Alt-F
Status: RESOLVED → REOPENED
Target Milestone: M13 → M15
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
Assignee: saari → pinkerton
Status: REOPENED → NEW
Taking menu/popup bugs.
We need a decision, folks. moving it back until then.
Whiteboard: Need a decision to be made here.
Target Milestone: M15 → M18
*** Bug 13332 has been marked as a duplicate of this bug. ***
Keywords: pp
bulk accepting xpmenu/popup bugs. sigh.
Status: NEW → ASSIGNED
moving all key-related menu bugs to hyatt, per his request.
Assignee: pinkerton → hyatt
Status: ASSIGNED → NEW
Summary: [PP]Alt-F not working on linux → Alt-F not working on linux
Shortcut mnemonics dead on Linux.
Status: NEW → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → INVALID
dead meaning they don't work? or we don't plan to implement this feature?
please clarify...
verified in 2/14 build....I guess dead means not implementing...
Status: RESOLVED → VERIFIED
Don't plan to implement.
You need to log in before you can comment on or make changes to this bug.