bugzilla lite should utilize persona sign in ( https://login.persona.org/sign_in )

RESOLVED DUPLICATE of bug 1141992

Status

Firefox OS
Gaia::Bugzilla Lite
P1
normal
RESOLVED DUPLICATE of bug 1141992
3 years ago
3 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [spark])

1. launch bugzilla lite

Expected: An option for persona sign in
Actual: no persona sign in.
Priority: -- → P1
Whiteboard: [ignite]
this is a limitation of bugzilla, not bzlite.

bugzilla's preferred auth mechanism for API calls is api-keys, and delegated authentication isn't supported.
one of the bmo team's goals for this quarter is to make this process of obtaining an api-key from bugzilla from other applications significantly easier (likely an oauth-like approval process).
See Also: → bug 1141992
Yup, gonna track using any newly developed oauth like flow in 1141992, otherwise not much we can do here
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1141992
Whiteboard: [ignite] → [spark]
Duplicate of this bug: 1171954
Duplicate of this bug: 1177225
Duplicate of this bug: 1189804
You need to log in before you can comment on or make changes to this bug.