[RTL][Settings]The distance between screen edge and "Passcode doesn't match." string is too small.

VERIFIED FIXED in 2.2 S11 (1may)

Status

P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yue.xia, Assigned: eragonj)

Tracking

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8593256 [details]
LTR&RTL_video.mp4

[1.Description]:
[RTL][Flame 2.2 & 3.0][Nexus 5 2.2 & 3.0][Settings]On  "New passcode" view, input wrong passcodes, the distance between screen edge and "Passcode doesn't match." string is too small.
See attachment: LTR&RTL_video.mp4

[2.Testing Steps]: 
Precondition: Insert a SIM card in device.
1. Set system language to Arabic and set a passcode.
2. Launch Settings app -> Call Settings -> Call Barring -> Change passcode.
3. Input current passcode and enter "New passcode" view.
4. Input wrong passcodes.

[3.Expected Result]: 
4. The distance between screen edge and "Passcode doesn't match." string should be correct.

[4.Actual Result]: 
4. The "Passcode doesn't match." string is displayed, but the distance between screen edge and "Passcode doesn't match." string is too small.

[5.Reproduction build]: 
Flame 2.2 (Affected)
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.201243
Firmware Date          Wed Apr 15 20:12:52 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (Affected)
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.192055
Firmware Date          Wed Apr 15 19:21:04 EDT 2015
Bootloader             L1TC000118D0

Nexus 5 2.2 (Affected)
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150415.200855
Firmware Date          Wed Apr 15 20:09:09 EDT 2015
Bootloader             HHZ12fBuild ID              

Nexus5 3.0 (Affected)
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150415.192113
Firmware Date          Wed Apr 15 19:21:33 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
(note: you need to download the video to be able to see it)
The problem here isn't that the string is too small - as I see it, it's that the right side of the string is cut off because it's positioning is shifted too much to the right.
Since this is an important error notification that is potentially confusing to users, I will nominate this.
blocking-b2g: --- → 2.2?

Comment 2

4 years ago
Triage:blocking
Assignee: nobody → ejchen
blocking-b2g: 2.2? → 2.2+
Triage: P2
Priority: -- → P2
Created attachment 8594662 [details] [review]
[gaia] EragonJ:bug-1155097 > mozilla-b2g:master
Comment on attachment 8594662 [details] [review]
[gaia] EragonJ:bug-1155097 > mozilla-b2g:master

Arthur can you help me review this simple patch ? Thanks !
Attachment #8594662 - Flags: review?(arthur.chen)
Comment on attachment 8594662 [details] [review]
[gaia] EragonJ:bug-1155097 > mozilla-b2g:master

r=me, thank you!
Attachment #8594662 - Flags: review?(arthur.chen) → review+
Keywords: checkin-needed
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Comment on attachment 8594662 [details] [review]
[gaia] EragonJ:bug-1155097 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no
[User impact] if declined: For RTL users, some wordings would be too close to the edge.
[Testing completed]: yes, I did test this manually 
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8594662 - Flags: approval-gaia-v2.2?

Comment 9

4 years ago
Created attachment 8595800 [details]
video.mp4

This issue has been verified passed on latest build of Flame 3.0 with the same steps in comment 0.
See attachment:video.MP4
Rate:0/5

Device: Flame 3.0 (pass)
Build ID               20150421160203
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/86725d1a2cf3
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.192130
Firmware Date          Tue Apr 21 19:21:42 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-master: fixed → verified
Attachment #8594662 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/321bad729466dbe854b9d09805cec69f134a443d
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S11 (1may)

Comment 11

4 years ago
Created attachment 8597059 [details]
video_pass.mp4

This issue has been verified passed on latest build of Flame 2.2 and Nexus_5 2.2/3.0 with the same steps in comment 0.
See attachment:video_pass.mp4
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150423162502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5fe76b26e55f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.195827
Firmware Date          Thu Apr 23 19:58:39 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (pass)
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.035409
Firmware Date          Thu Apr 23 03:54:27 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (pass)
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.192918
Firmware Date          Thu Apr 23 19:29:36 EDT 2015
Bootloader             HHZ12f

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.