Assertion failure: aRect.TopLeft() == nsIntPoint(0, 0) (Expecting rect for whole frame), at c:\Users \mozilla\debug-builds\mozilla-central\dom\plugins\ipc\PluginInstanceParent.cpp:802

RESOLVED INCOMPLETE

Status

()

Core
Plug-ins
RESOLVED INCOMPLETE
3 years ago
7 months ago

People

(Reporter: Tomcat, Unassigned)

Tracking

(Blocks: 1 bug, {assertion})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
Found via Bughunter and reproduce on a Windows 7 Trunk Debug Build.

Steps to reproduce:

-> Load http://www.ytrg.terengganu.gov.my/v3/index.php/hubungi/maklum-balas
--> Assertion failure: aRect.TopLeft() == nsIntPoint(0, 0) (Expecting rect for whole frame), at c:\Users \mozilla\debug-builds\mozilla-central\dom\plugins\ipc\PluginInstanceParent.cpp:802

#01: mozilla::plugins::PluginModuleParent::BeginUpdateBackground (c:\users\mozilla\debug-builds\mozi
lla-central\dom\plugins\ipc\pluginmoduleparent.cpp:1884)
#02: nsNPAPIPluginInstance::BeginUpdateBackground (c:\users\mozilla\debug-builds\mozilla-central\dom
\plugins\base\nsnpapiplugininstance.cpp:1258)
#03: nsPluginInstanceOwner::BeginUpdateBackground (c:\users\mozilla\debug-builds\mozilla-central\dom
\plugins\base\nsplugininstanceowner.cpp:270)
#04: PluginBackgroundSink::BeginUpdate (c:\users\mozilla\debug-builds\mozilla-central\layout\generic
\nspluginframe.cpp:134)
#05: mozilla::layers::RemoteBufferReadbackProcessor::ProcessReadback (c:\users\mozilla\debug-builds\
mozilla-central\gfx\layers\client\contentclient.cpp:204)
#06: mozilla::layers::DIBTextureClient::Unlock (c:\users\mozilla\debug-builds\mozilla-central\gfx\la
yers\texturedib.cpp:64)
#07: mozilla::layers::ContentClientRemoteBuffer::EndPaint (c:\users\mozilla\debug-builds\mozilla-cen
tral\gfx\layers\client\contentclient.cpp:267)
#08: mozilla::layers::ClientPaintedLayer::RenderLayerWithReadback (c:\users\mozilla\debug-builds\moz
illa-central\gfx\layers\client\clientpaintedlayer.cpp:133)
#09: mozilla::layers::ClientContainerLayer::RenderLayer (c:\users\mozilla\debug-builds\mozilla-centr
al\gfx\layers\client\clientcontainerlayer.h:71)
#10: mozilla::layers::ClientLayer::RenderLayerWithReadback (c:\users\mozilla\debug-builds\mozilla-ce
ntral\gfx\layers\client\clientlayermanager.h:379)
#11: mozilla::layers::ClientLayerManager::EndTransactionInternal (c:\users\mozilla\debug-builds\mozi
lla-central\gfx\layers\client\clientlayermanager.cpp:273)
#12: mozilla::layers::ClientLayerManager::EndTransaction (c:\users\mozilla\debug-builds\mozilla-cent
ral\gfx\layers\client\clientlayermanager.cpp:316)
#13: nsDisplayList::PaintRoot (c:\users\mozilla\debug-builds\mozilla-central\layout\base\nsdisplayli
st.cpp:1780)
#14: nsLayoutUtils::PaintFrame (c:\users\mozilla\debug-builds\mozilla-central\layout\base\nslayoutut
ils.cpp:3273)
#15: PresShell::Paint (c:\users\mozilla\debug-builds\mozilla-central\layout\base\nspresshell.cpp:633
1)
#16: nsViewManager::ProcessPendingUpdatesPaint (c:\users\mozilla\debug-builds\mozilla-central\view\n
sviewmanager.cpp:445)
#17: nsViewManager::ProcessPendingUpdatesForView (c:\users\mozilla\debug-builds\mozilla-central\view
\nsviewmanager.cpp:381)
#18: nsViewManager::ProcessPendingUpdates (c:\users\mozilla\debug-builds\mozilla-central\view\nsview
manager.cpp:1076)
#19: nsRefreshDriver::DoTick (c:\users\mozilla\debug-builds\mozilla-central\layout\base\nsrefreshdri
ver.cpp:1387)
#20: nsRefreshDriver::FinishedWaitingForTransaction (c:\users\mozilla\debug-builds\mozilla-central\l
ayout\base\nsrefreshdriver.cpp:1860)
#21: mozilla::layers::ClientLayerManager::DidComposite (c:\users\mozilla\debug-builds\mozilla-centra
l\gfx\layers\client\clientlayermanager.cpp:395)
#22: mozilla::layers::CompositorChild::RecvDidComposite (c:\users\mozilla\debug-builds\mozilla-centr
al\gfx\layers\ipc\compositorchild.cpp:348)
#23: mozilla::layers::PCompositorChild::OnMessageReceived (c:\users\mozilla\debug-builds\mozilla-cen
tral\firefox-debug\ipc\ipdl\pcompositorchild.cpp:820)
#24: mozilla::ipc::MessageChannel::DispatchAsyncMessage (c:\users\mozilla\debug-builds\mozilla-centr
al\ipc\glue\messagechannel.cpp:1250)
#25: mozilla::ipc::MessageChannel::DispatchMessageW (c:\users\mozilla\debug-builds\mozilla-central\i
pc\glue\messagechannel.cpp:1168)
#26: mozilla::ipc::MessageChannel::OnMaybeDequeueOne (c:\users\mozilla\debug-builds\mozilla-central\
ipc\glue\messagechannel.cpp:1152)
#27: MessageLoop::RunTask (c:\users\mozilla\debug-builds\mozilla-central\ipc\chromium\src\base\messa
ge_loop.cc:362)
#28: MessageLoop::DeferOrRunPendingTask (c:\users\mozilla\debug-builds\mozilla-central\ipc\chromium\
src\base\message_loop.cc:372)
#29: MessageLoop::DoWork (c:\users\mozilla\debug-builds\mozilla-central\ipc\chromium\src\base\messag
e_loop.cc:456)
#30: mozilla::ipc::DoWorkRunnable::Run (c:\users\mozilla\debug-builds\mozilla-central\ipc\glue\messa
gepump.cpp:234)
#31: nsThread::ProcessNextEvent (c:\users\mozilla\debug-builds\mozilla-central\xpcom\threads\nsthrea
d.cpp:866)
#32: NS_ProcessNextEvent (c:\users\mozilla\debug-builds\mozilla-central\xpcom\glue\nsthreadutils.cpp
:265)
#33: mozilla::ipc::MessagePump::Run (c:\users\mozilla\debug-builds\mozilla-central\ipc\glue\messagep
ump.cpp:140)
#34: MessageLoop::RunInternal (c:\users\mozilla\debug-builds\mozilla-central\ipc\chromium\src\base\m
essage_loop.cc:233)
#35: MessageLoop::RunHandler (c:\users\mozilla\debug-builds\mozilla-central\ipc\chromium\src\base\me
ssage_loop.cc:227)
#36: MessageLoop::Run (c:\users\mozilla\debug-builds\mozilla-central\ipc\chromium\src\base\message_l
oop.cc:201)
#37: nsBaseAppShell::Run (c:\users\mozilla\debug-builds\mozilla-central\widget\nsbaseappshell.cpp:16
6)
#38: nsAppShell::Run (c:\users\mozilla\debug-builds\mozilla-central\widget\windows\nsappshell.cpp:18
0)
#39: nsAppStartup::Run (c:\users\mozilla\debug-builds\mozilla-central\toolkit\components\startup\nsa
ppstartup.cpp:282)
#40: XREMain::XRE_mainRun (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nsapprunner.cpp
:4173)
#41: XREMain::XRE_main (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nsapprunner.cpp:42
53)
#42: XRE_main (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nsapprunner.cpp:4472)
#43: do_main (c:\users\mozilla\debug-builds\mozilla-central\browser\app\nsbrowserapp.cpp:294)
#44: NS_internal_main (c:\users\mozilla\debug-builds\mozilla-central\browser\app\nsbrowserapp.cpp:66
7)
#45: wmain (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nswindowswmain.cpp:124)
#46: __tmainCRTStartup (f:\dd\vctools\crt\crtw32\startup\crt0.c:255)
#47: BaseThreadInitThunk[kernel32 +0x4ee1c]
#48: RtlInitializeExceptionChain[ntdll +0x637eb]
#49: RtlInitializeExceptionChain[ntdll +0x637be]

Comment 1

3 years ago
Tomcat, I can't reproduce this one in automation. Can you?
Flags: needinfo?(cbook)
(Reporter)

Comment 2

3 years ago
(In reply to Bob Clary [:bc:] from comment #1)
> Tomcat, I can't reproduce this one in automation. Can you?

hm did several tries and dont'crashed so far
Flags: needinfo?(cbook)

Comment 3

3 years ago
Ok. lets call it wfm for now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 4

3 years ago
Tomcat, I just looked at bughunter and found this reproduced on Windows for beta and http://mil.news.sina.com.cn/?from=wap

If you can investigate more we can maybe reopen it for Beta/39.
Flags: needinfo?(cbook)

Comment 5

2 years ago
I can reproduce with Nightly/45 on Windows 7 32bit just loading:

http://nontonfilm81.com/category/18/page/2/ (Slightly NSFW)

I can't reproduce with a saved version so get it while you can. For what is it worth, autophone showed a different crash/assertion. I found this manually loading the url from the command line.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 6

2 years ago
Another example: http://yakyulive.blogspot.jp/p/all-ch.html?m=1
(Reporter)

Comment 7

2 years ago
does not crash anymore for me, seems we fixed this at some point ? bc: closing as wfm ?
Flags: needinfo?(cbook) → needinfo?(bob)

Comment 8

2 years ago
We've only seen this on one url since the beginning of the year when we retested all of the urls. It also involved flash which we no longer test. Retesting the urls in this bug via automation did not reproduce, nor did manual testing the one url which reproduced this issue though I got a 400 Bad Request for that url.

This assertion may have only been Flash related. Tomcat, see if you can reproduce with Flash and if not we can wfm this.
Flags: needinfo?(bob)

Comment 9

2 years ago
I forgot to mention that the one url that reproduced this was for Beta rv:44.0 20160118120031 Windows 7.

Comment 10

7 months ago
Resolving old bugs which are likely not relevant any more, since NPAPI plugins are deprecated.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago7 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.