Sound cut off in short youtube videos(with HTML5 player)

RESOLVED INVALID

Status

()

Core
Audio/Video: Playback
P5
normal
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: kalviskajaks, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-IE], URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150415030206

Steps to reproduce:

1) Open a short few seconds long video on Youtube, which has sound shortly before the end.
2) Make sure the HTML5 player is used
3) Play the video

Example videos 
https://www.youtube.com/watch?v=rh8m2-q71qQ
https://www.youtube.com/watch?v=7LlIKtQwIxI (you can see the mouth still moving while the sounds just disappears)


Actual results:

Video plays fine, but sounds disappears shortly before the end.


Expected results:

Sound should play all the way to the end. Which it does if Flash player is used instead of the HTML5 player.
(Reporter)

Updated

3 years ago
Component: Untriaged → Video/Audio
Product: Firefox → Core
(Reporter)

Comment 1

2 years ago
Happens in Chrome too, so probably a youtube bug not a Firefox one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

2 years ago
Ok. Apparently Youtube now serves HTML5 to IE too. And surprisingly IE manages to not cut off the end. Well if IE can do it, why not Firefox. so reopening..?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Whiteboard: [parity-IE]
Version: 40 Branch → unspecified
The end of the audio in https://www.youtube.com/watch?v=rh8m2-q71qQ is cut off for me in IE Edge (and Firefox and Chrome).  I get "A few" in all three.  Same with the other video.

Curiously, if I download the MP4 and WebM versions with youtube-dl, less of the audio is cut off.  I get "A few moments later" (but it cuts mid-"r"), so the actual media is longer and plays fully in VLC, Firefox, and Chrome.  Same with the other video.

So this does look like a YouTube-side issue.  What video and IE version were you seeing complete playback with?
(Reporter)

Comment 4

2 years ago
https://www.youtube.com/watch?v=7LlIKtQwIxI

Windows 7, IE 11, i can clearly hear all of "unbearable faggots" where as in Firefox all i hear is "unbearab"
Hitting refresh gives me different amounts of audio each time.
If I disable MSE by setting media.mediasource.enabled to false, I get consistent playback of all audio... could be a timing/buffer appending issue with the MSE player.
(Reporter)

Comment 7

2 years ago
OK, i tried mozregression for **** and giggles, and the results are

last good build

build_date: 2014-03-16
build_txt_url: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/03/2014-03-16-03-02-02-mozilla-central/firefox-30.0a1.en-US.win64-x86_64.txt
build_type: nightly
build_url: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/03/2014-03-16-03-02-02-mozilla-central/firefox-30.0a1.en-US.win64-x86_64.zip
changeset: e3b76b155ca4
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e3b76b155ca4&tochange=5d61fabc49a8
repo: mozilla-central
repository: https://hg.mozilla.org/mozilla-central

first bad

build_date: 2014-03-17
build_txt_url: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/03/2014-03-17-16-58-01-mozilla-central/firefox-31.0a1.en-US.win64-x86_64.txt
build_type: nightly
build_url: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/03/2014-03-17-16-58-01-mozilla-central/firefox-31.0a1.en-US.win64-x86_64.zip
changeset: 5d61fabc49a8
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=82c90c17fc95&tochange=082761b7bc54
repo: mozilla-central
repository: https://hg.mozilla.org/mozilla-central

Note i had to force youtube to give me html5, because for older versions it automatically wants to revert to flash.
Component: Audio/Video → Audio/Video: Playback
Priority: -- → P5
(Reporter)

Comment 8

2 years ago
Well i just found out the "Magic options" addon causes this. Its "auto replay" option restarts the video before it reaches the end. If i disable it the problem goes away. Other addons which have this option might  be affected too. Anyways, marking this as resolved because its not an Firefox bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.