Awful blurry fonts in popup windows and menus after landing patch from bug #1150376

VERIFIED FIXED in Firefox 38

Status

()

Core
Graphics: Layers
--
major
VERIFIED FIXED
3 years ago
5 months ago

People

(Reporter: Virtual, Assigned: bas)

Tracking

({nightly-community, regression})

40 Branch
mozilla40
x86_64
Windows 7
nightly-community, regression
Points:
---

Firefox Tracking Flags

(firefox37 unaffected, firefox38+ verified, firefox39+ verified, firefox40+ verified)

Details

Attachments

(6 attachments)

Regression window (mozilla-inbound-win32)
Good:
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1429128677/

Bad:
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1429129638/

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2a81e53f2624&tochange=dc3f816f39ce

Caused by:
Bug 1150376: Do not try to use D3D11 for popup windows. r=jrmuizel



[Tracking Requested - why for this release]: Regression
Created attachment 8593415 [details]
good1.png
Created attachment 8593416 [details]
bad1.png
Created attachment 8593417 [details]
good2.png
Created attachment 8593418 [details]
bad2.png

Comment 5

3 years ago
I have seen this in today's nightly too (win32 build, Win 8.1 x64, All D2D1.1/DX11 stuff active, Nvidia GTX650, latest drivers).
Tracking for 40. 

Florin, can you have a look to see if this regression also affects 38 and 39 since we uplifted the patch in bug 1150376?   We may just end up backing out that patch.
tracking-firefox40: ? → +
Flags: needinfo?(florin.mezei)
This doesn't look "blurry" to me, it just looks like the text hinting is different.  Likely due to different rendering mechanism in use (no D2D/DWrite after the patch maybe?)
I talked to Bas about this. We're going to change this so that it only happens when using WARP.
Assignee: nobody → bas
Status: NEW → ASSIGNED
(Assignee)

Comment 9

3 years ago
Created attachment 8593559 [details] [diff] [review]
Only use Basic OMTC when using WARP.
Attachment #8593559 - Flags: review?(jmuizelaar)
Attachment #8593559 - Flags: review?(jmuizelaar) → review+
It seems that 38 and 39 are not affected by this issue.

Tested on Windows 7 64-bit with:
- latest Aurora, build ID: 20150416004008;
- Firefox 38 beta 5, build ID: 20150416143048.
status-firefox38: ? → unaffected
status-firefox39: ? → unaffected
Flags: needinfo?(florin.mezei)

Comment 11

3 years ago
On my machine this issue is like some characters is "broken". Windows7 and firefox nightly v40 x64 edition.

Comment 12

3 years ago
Created attachment 8593974 [details]
Another situation of this issue
tracking-firefox38: ? → ---
tracking-firefox39: ? → ---

Comment 13

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/84a83069abb5
https://hg.mozilla.org/mozilla-central/rev/84a83069abb5
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Jeff, Bas, can we have an uplift request for this bug? (needed if we uplift 1150376)
Thanks
tracking-firefox38: --- → +
Flags: needinfo?(jmuizelaar)
Flags: needinfo?(bas)
Comment on attachment 8593559 [details] [diff] [review]
Only use Basic OMTC when using WARP.

Approval Request Comment
[Feature/regressing bug #]: 1150376
[User impact if declined]: Worse text rendering in popup menus
[Describe test coverage new/current, TreeHerder]: On trunk for a day or two
[Risks and why]: Low risk. We're just reverting to a path that that's already exercised.
Flags: needinfo?(jmuizelaar)
Attachment #8593559 - Flags: approval-mozilla-beta?
Attachment #8593559 - Flags: approval-mozilla-aurora?
Comment on attachment 8593559 [details] [diff] [review]
Only use Basic OMTC when using WARP.

Should be in 38 beta 6.
Attachment #8593559 - Flags: approval-mozilla-beta?
Attachment #8593559 - Flags: approval-mozilla-beta+
Attachment #8593559 - Flags: approval-mozilla-aurora?
Attachment #8593559 - Flags: approval-mozilla-aurora+
Confirming this fix on Windows 7 64-bit using latest Firefox Nightly, build ID: 20150419030206.
Status: RESOLVED → VERIFIED
status-firefox40: fixed → verified
QA Contact: cornel.ionce
status-firefox38: unaffected → affected
status-firefox39: unaffected → affected
Flags: needinfo?(bas)
https://hg.mozilla.org/releases/mozilla-aurora/rev/a4e7361a2b5d
status-firefox39: affected → fixed
https://hg.mozilla.org/releases/mozilla-beta/rev/4dc8d874746b
status-firefox38: affected → fixed
status-firefox38: fixed → verified
status-firefox39: fixed → verified
tracking-firefox39: --- → ?
tracking-firefox39: ? → +
Keywords: nightly-community
QA Contact: cornel.ionce → Virtual
You need to log in before you can comment on or make changes to this bug.