15% Win7 tp5n regression on Mozilla-Inbound-Non-PGO (v. 40) on April 15, 2015 from push 304f87a54059

RESOLVED FIXED in Firefox 40

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: vaibhav1994, Unassigned)

Tracking

unspecified
mozilla40
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 fixed)

Details

Talos has detected a Firefox performance regression from your commit 304f87a54059 in bug 1153937.  We need you to address this regression.

This is a list of all known regressions and improvements related to your bug:
http://alertmanager.allizom.org:8080/alerts.html?rev=304f87a54059&showAll=1

On the page above you can see Talos alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test, please see: https://wiki.mozilla.org/Buildbot/Talos/Tests#xperf

Reproducing and debugging the regression:
If you would like to re-run this Talos test on a potential fix, use try with the following syntax:
try: -b o -p win32 -u none -t xperf  # add "mozharness: --spsProfile" to generate profile data

To run the test locally and do a more in-depth investigation, first set up a local Talos environment:
https://wiki.mozilla.org/Buildbot/Talos/Running#Running_locally_-_Source_Code

Then run the following command from the directory where you set up Talos:
talos --develop -e <path>/firefox -a tp5n

Making a decision:
As the patch author we need your feedback to help us handle this regression.
*** Please let us know your plans by Monday, or the offending patch will be backed out! ***

Our wiki page oulines the common responses and expectations:
https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
:dougt, can you look into this figure out what is causing this regression?
Flags: needinfo?(dougt)
Backout (but leaving tests alone).  This should address the problem.

   https://hg.mozilla.org/integration/mozilla-inbound/rev/5782e3653c5d
Flags: needinfo?(dougt)
Thanks Doug!  If you want any help understanding the regression or how to fix/accept it for relanding, do ask.
I am delaying all IO until final-ui-startup.  I pushed a change to try to make this io happen at sessionstore-windows-restored.  Do we just white list this?
Flags: needinfo?(aklotz)
yeah, moving to sessionstore-windows-restored worked:


Improvement: Mozilla-Inbound-Non-PGO - Tp5 No Network Row Major MozAfterPaint (Non-Main Startup File IO Bytes) - WINNT 6.1 (ix) - 16.1% decrease
------------------------------------------------------------------------------------------------------------------------------------------------
   Previous: avg 898905.750 stddev 48030.632 of 12 runs up to revision 3f4103872afc
   New     : avg 754366.167 stddev 6849.277 of 12 runs since revision 5782e3653c5d
   Change  : -144539.583 (16.1% / z=3.009)
   Graph   : http://mzl.la/1EP2TJv
Based on this last comment I don't think you should need to whitelist anything.
Flags: needinfo?(aklotz)
https://hg.mozilla.org/mozilla-central/rev/5782e3653c5d
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.