Trunk Crash when visiting webpages with redirections [@ nsTimerImpl::Process]

VERIFIED FIXED in mozilla0.9.8

Status

SeaMonkey
General
P1
critical
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Vadim Berezniker, Assigned: Stuart Parmenter)

Tracking

({crash, topcrash})

Trunk
mozilla0.9.8
x86
All
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment, 1 obsolete attachment)

3.46 KB, patch
Ben Goodger (use ben at mozilla dot org for email)
: review+
Scott MacGregor
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Mozilla 2001121606 crashes immediately upon entering this site.
Talkback id: TB555964W

Comment 1

16 years ago
Also crashing 20011216 on Win2k.
OS -> All.

another redirection crasher ?

Stephen, can you retreive Talkback data please ?
Severity: normal → critical
Keywords: crash
OS: Linux → All
(Reporter)

Comment 2

16 years ago
You're right.
I used netscape 4 to go that address and then took the address after redirection
and pasted it to mozilla and everything was fine.
So whatever the reason for it crashing, it probably happens during redirection.
Sorry, that ID comes up empty.  cc: me if you get another, thanks.
(Reporter)

Comment 4

16 years ago
Easy does it: TB557874Q

Comment 5

16 years ago
It crashes on linux too, 2001-121606
TB: TB558090X
(2001-121506: No crash)

Comment 6

16 years ago
*** Bug 115531 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
*** Bug 115529 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Problem is with <meta http-equiv="refresh" content="1;url=url_here">

Whatever it is, it was caused by a checking yesterday
Updating summary and setting new as bug 115529
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: immediate crash at http://go.to/kg7faq → Crash when visiting webpages with redirections
It's timer code, and I think it might belong to pavlov@netscape.com.  Here's my
own stack.
Stack Signature  nsTimerImpl::Process 22202294
Trigger Time 2001-12-16 15:12:51
Email Address stephend@netscape.com
URL visited http://home.netscape.com
User Comments Crashed on a redirect
Build ID 2001121611
Product ID MozillaTrunk
Platform
Operating System Win32
Module
Trigger Reason Access violation
Stack Trace
nsTimerImpl::Process [d:\builds\seamonkey\mozilla\xpcom\threads\nsTimerImpl.cpp,
line 236]
handleMyEvent [d:\builds\seamonkey\mozilla\xpcom\threads\nsTimerImpl.cpp, line 267]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 303]
netscp6.exe + 0x167e (0x0040167e)
netscp6.exe + 0x121c (0x0040121c)
netscp6.exe + 0x3222 (0x00403222)
KERNEL32.DLL + 0x17d08 (0x77e97d08) 
(Assignee)

Comment 10

16 years ago
Created attachment 61917 [details] [diff] [review]
Fix

this patch doesn't actually fix the crash in the url above, but the stack is
completly different.
the new timers weren't addrefing the nsITimerCallback interface that was passed
to it.	now it does.
So, for the actual crash as this bug was filed (http://go.to/kg7faq), here is my
stack:

Stack Signature  gkcontent.dll + 0xff81d (0x01b3f81d) f2e072ed
Trigger Time 2001-12-16 19:25:26
Email Address stephend@netscape.com
URL visited http://go.to/kg7faq
User Comments
Build ID 2001121611
Product ID MozillaTrunk
Platform
Operating System Win32
Module
Trigger Reason Access violation
Stack Trace
gkcontent.dll + 0xff81d (0x01b3f81d)
SETUPAPI.DLL + 0x30c24 (0x778b0c24) 

Comment 12

16 years ago
linux cvs, some 5h old, stack for http://go.to/kg7faq

#0  0x4014ae89 in nsTimerImpl::Process () from libxpcom.so
#1  0x4014aedf in handleMyEvent () from libxpcom.so
#2  0x40146fef in PL_HandleEvent () from libxpcom.so
#3  0x401473ff in PL_ProcessEventsBeforeID () from libxpcom.so
#4  0x406f7c43 in processQueue () from libwidget_gtk.so
#5  0x40117097 in nsVoidArray::EnumerateForwards () from libxpcom.so
#6  0x406f7c80 in nsAppShell::ProcessBeforeID () from libwidget_gtk.so
#7  0x406fe64e in handle_gdk_event () from libwidget_gtk.so
#8  0x4035316b in gdk_event_dispatch (source_data=0x0, current_time=0xbffff430,
user_data=0x0) at gdkevents.c:2139
#9  0x40384055 in g_main_dispatch (dispatch_time=0xbffff430) at gmain.c:656
#10 0x40384659 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#11 0x403847e8 in g_main_run (loop=0x81f4b30) at gmain.c:935
#12 0x4029865b in gtk_main () at gtkmain.c:524
#13 0x406f79c5 in nsAppShell::Run () from libwidget_gtk.so
#14 0x406da17e in nsAppShellService::Run () from libnsappshell.so
#15 0x080516db in main1 ()
#16 0x08052009 in main ()
#17 0x404cc627 in __libc_start_main (main=0x8051ed0 <main>, argc=1,
ubp_av=0xbffff834, init=0x804bf44 <_init>, fini=0x8052edc <_fini>,
rtld_fini=0x4000dcc4 <_dl_fini>, stack_end=0xbffff82c)
    at ../sysdeps/generic/libc-start.c:129
(Assignee)

Updated

16 years ago
Attachment #61917 - Attachment is obsolete: true

Comment 13

16 years ago
*** Bug 115524 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

16 years ago
Created attachment 61927 [details] [diff] [review]
Real fix

This patch fixes the problems by addrefing/releasing the nsITimerCallback as
well as removing a useless addref/release of the timer and shuffling a release
back in to the timer so that it always gets released on the right thread.

Updated

16 years ago
Keywords: review
(Assignee)

Comment 15

16 years ago
reassigning to self
Assignee: asa → pavlov
Priority: -- → P1
Target Milestone: --- → mozilla0.9.8

Comment 16

16 years ago
Comment on attachment 61927 [details] [diff] [review]
Real fix

sr=mscott
Attachment #61927 - Flags: superreview+
Comment on attachment 61927 [details] [diff] [review]
Real fix

r=ben@netscape.com
Attachment #61927 - Flags: review+
(Assignee)

Comment 18

16 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 19

16 years ago
*** Bug 115595 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
*** Bug 115598 has been marked as a duplicate of this bug. ***

Comment 21

16 years ago
*** Bug 115615 has been marked as a duplicate of this bug. ***
*** Bug 115685 has been marked as a duplicate of this bug. ***
*** Bug 115781 has been marked as a duplicate of this bug. ***

Comment 24

16 years ago
Adding talkback keywords and stack so we can track/verify this one.
Keywords: topcrash
Summary: Crash when visiting webpages with redirections → Trunk Crash when visiting webpages with redirections [@ nsTimerImpl::Process]
*** Bug 115679 has been marked as a duplicate of this bug. ***
*** Bug 115578 has been marked as a duplicate of this bug. ***
*** Bug 115596 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
Verified Fixed.  Talkback data shows this last crashed on 12/17 (only 2 crashes
with that day's builds after seeing 388 crashes with 12/16 builds)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Crash Signature: [@ nsTimerImpl::Process]
You need to log in before you can comment on or make changes to this bug.