If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Too much recursion - broken debugger in Browser Toolbox

RESOLVED DUPLICATE of bug 1149910

Status

()

Firefox
Developer Tools: Debugger
RESOLVED DUPLICATE of bug 1149910
3 years ago
3 years ago

People

(Reporter: marcosc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
When setting a breakpoint in the Browser Toolbox, when the break actually happens, I get: 

[Parent 69157] WARNING: Reentrancy error: some client attempted to display a message to the console while in a console listener. The following message was discarded: "[JavaScript Error: "too much recursion" {file: "resource://gre/modules/devtools/Loader.jsm" line: 319}]": file /Users/marcos/gecko/xpcom/base/nsConsoleService.cpp, line 191
JavaScript error: resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/script.js, line 1905: too much recursion

This makes debugging not work, obviously. As it just craps out with "Too much recursion" over and over again.
(Reporter)

Updated

3 years ago
Summary: Too much recursion → Too much recursion - broken debugger in Browser Toolbox
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149910
You need to log in before you can comment on or make changes to this bug.