Closed Bug 1155295 Opened 5 years ago Closed 5 years ago

Search clear button is off centered

Categories

(DevTools :: General, defect, P2)

x86
macOS
defect

Tracking

(firefox44 verified)

VERIFIED FIXED
Firefox 44
Tracking Status
firefox44 --- verified

People

(Reporter: gl, Assigned: jsantell)

References

Details

(Whiteboard: [polish-backlog][difficulty=easy])

Attachments

(2 files, 1 obsolete file)

In bug 1120616, we enabled the search clear button visibility for all the search boxes in the devtools. This is a follow up to fix its style since it is a bit off centered.
Whiteboard: [devedition-40][difficulty=easy]
Priority: -- → P2
Whiteboard: [devedition-40][difficulty=easy] → [polish-backlog][difficulty=easy]
Assignee: nobody → jsantell
Blocks: de-44-polish
Status: NEW → ASSIGNED
Attached patch 1155295-offcenter-search.patch (obsolete) — Splinter Review
This only affects search fields in the inspector, console (the inspector's sidebar searches are fine)

gl, this is mostly your code, so pinging for review, but can ping someone else if you're globetrotting!
Attachment #8668238 - Flags: review?(gabriel.luong)
Comment on attachment 8668238 [details] [diff] [review]
1155295-offcenter-search.patch

Review of attachment 8668238 [details] [diff] [review]:
-----------------------------------------------------------------

Switching to bgrins
Attachment #8668238 - Flags: review?(gabriel.luong) → review?(bgrinstead)
Comment on attachment 8668238 [details] [diff] [review]
1155295-offcenter-search.patch

Review of attachment 8668238 [details] [diff] [review]:
-----------------------------------------------------------------

::: devtools/client/themes/toolbars.inc.css
@@ +434,5 @@
>    -moz-image-region: rect(0, 16px, 16px, 0);
>  }
>  
> +.devtools-searchinput > .textbox-input-box > .textbox-search-icons > .textbox-search-clear {
> +  margin-top: 1px;

I think we want margin-bottom: 0 (or margin: 0) instead since that will override https://dxr.mozilla.org/mozilla-central/source/toolkit/themes/osx/global/textbox.css?offset=0#81.  Adding 1px to the margin has a chance of bumping it out of alignment on Windows / Linux where they are already set to 0px margin.
Attachment #8668238 - Flags: review?(bgrinstead)
This works too!
Attachment #8668238 - Attachment is obsolete: true
Attachment #8670541 - Flags: review?(bgrinstead)
Comment on attachment 8670541 [details] [diff] [review]
1155295-offcenter-search.patch

Review of attachment 8670541 [details] [diff] [review]:
-----------------------------------------------------------------

nice
Attachment #8670541 - Flags: review?(bgrinstead) → review+
https://hg.mozilla.org/mozilla-central/rev/ff9369b7fc23
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
Attached image bug-1155295.png
¡Hola Gabriel!

I'm trying to verify this for https://quality.mozilla.org/event/bug-verification-day-85/

Attached is how this looks like on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0 ID:20151007030205 CSet: d1c5a7c5b4331ee9ea5443de893fcfd0a5b80e2a

Do these look about right or am I looking at the wrong places?

¡Gracias!
Flags: needinfo?(gabriel.luong)
Redirecting request to Jordan
Flags: needinfo?(gabriel.luong) → needinfo?(jsantell)
Looks good to me!
Flags: needinfo?(jsantell)
I have reproduced this bug on Firefox nightly Version 40.0a1 according to (2015-04-16) 

It is fixed and verified on Latest Developer Edition
Build ID 	20151103004217
User Agent 	Mozilla/5.0 (Windows NT 6.3; rv:44.0) Gecko/20100101 Firefox/44.0

Tested OS--Windows 8.1 32bit
QA Whiteboard: [bugday-20151104]
I have reproduced this bug on Nightly 40.0a1 (2015-04-16) on ubuntu 14.04 LTS, 32 bit!

The bug's fix is now verified on Latest Nightly 45.0a1!

Build ID: 20151117030242
User Agent: Mozilla/5.0 (X11; Linux i686; rv:45.0) Gecko/20100101 Firefox/45.0

[bugday-20151118]
As this bug is verified on both windows (Comment 11) and Linux (Comment 12), I am marking this bug verified.
Status: RESOLVED → VERIFIED
QA Whiteboard: [bugday-20151104] → [bugday-20151104][bugday-20151116]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.