dzm.com - "Definition" list layed out inconsistently with Netscape Communicator

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Joe McCabe, Assigned: bc)

Tracking

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
A definition list will layout inconsistently between modern builds of Mozilla
and Netscape's Communicator 4.x browser.

<dl>
  <dt>
     Foobar

  <dd>
     A misc token used to represent any data
</dl>

Will render as:


Foobar A misc token used to represent any data


in Moz 2001121408, but will render as:


Foobar
       A misc token used to represent any data


in Communicator.

Screenshot attached showing inconsistency in action.
(Reporter)

Comment 1

16 years ago
Created attachment 61909 [details]
Shows layout of Definition list in Mozilla 2001121408 and Netscape Communicator 4.x
This is probably invalid or evangelism but since NS4 displays it properly, I
will confirm it.

It seems that nearly every single <font> tag has no complimentary </font> 
Running tidy on the page to close out the <font> tag mess gets it to display
properly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 61911 [details]
Site after running tidy
->Evang
Component: Layout → English: US
Product: Browser → Tech Evangelism
Version: other → unspecified
(Reporter)

Comment 5

16 years ago
OK - I've played with the test case a bit and have come up with exactly
reproducable results and rules:

1) Caused by unclosed font tag
2) List _must_ be in a table

What this means is that an unclosed font tag will not cause the bad formatting
if the list is not inside a table.

Attaching sample HTML that shows problem. Same test case repeated twice - once
in a table and once not.
(Reporter)

Comment 6

16 years ago
Created attachment 61985 [details]
HTML snippet that illustrates broken layout vs. functional layout
(Reporter)

Comment 7

16 years ago
Created attachment 62071 [details]
Corrected test case HTML

Previous example had incorrectly closed <table> tag that prevented display in
Communicator. Revised HTML displays correctly in Communicator.

This should obsolete the previous attachment (61985).
jmccabe, this can be either evangelised or marked as a dupe of bug 5119.  Right
now it is marked for evangelism.  The unclosed <font> is illegal in HTML and
when we hit this, the <dd> is no longer within a <dl> but a <font> instead.  The
quirk for this is bug 5119 which used to work but does no longer.  It is marked
P5 future so it won't be fixed anytime soon unless the site author fixes his page.

Re-assigning to default evangelism owners.  My attachment 61911 [details] is the fixed
version of the site.
Assignee: attinasi → bclary
QA Contact: petersen → zach
(Reporter)

Comment 9

16 years ago
I understand that this is being treated as an evangelism issue. I disagree with
this, but that's not my call.

I admit that the unclosed <font> tag is illegal HTML, but the fact of the matter
is that IE and Communicator render the layout correctly. It seems to me that
this should be a defect given that Mozilla correctly lays out the illegal HTML
_unless_ it is in a table cell.
(Assignee)

Comment 10

16 years ago
harish, shouldn't we handle this kind of broken markup better in quirks mode ?
Seems that there are sufficient hints to tell the parser when to close the open
tags and such. What do you think?
(Assignee)

Updated

16 years ago
Summary: "Definition" list layed out inconsistently with Netscape Communicator → dzm.com - "Definition" list layed out inconsistently with Netscape Communicator
(Reporter)

Comment 11

16 years ago
Removed "dzm.com" from Subject and URL: field. Site owner has corrected HTML to
lay out correctly.
Summary: dzm.com - "Definition" list layed out inconsistently with Netscape Communicator → "Definition" list layed out inconsistently with Netscape Communicator
(Assignee)

Comment 12

16 years ago
Joe, when you take over Tech Evangelism for English US then you can manage your
bugs anyway you please. But as long as I have this bug then don't re-edit my bugs.

per comments -> fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Summary: "Definition" list layed out inconsistently with Netscape Communicator → dzm.com - "Definition" list layed out inconsistently with Netscape Communicator

Comment 13

16 years ago
Site looks ok in mac bits from 12/19/2001. Verif
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.