Closed Bug 1155477 Opened 4 years ago Closed 4 years ago

Convert nsINode::Slots::mChildNodes to an nsRefPtr

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: ehsan, Assigned: ehsan)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

MSVC 7 is no longer supported, so this can now be an nsRefPtr.
Attachment #8593697 - Flags: review?(amarchesini)
Assignee: nobody → ehsan
Blocks: 1114683
Comment on attachment 8593697 [details] [diff] [review]
Convert nsINode::Slots::mChildNodes to an nsRefPtr

This requires moving nsChildContentList to nsINode as well...
Attachment #8593697 - Attachment is obsolete: true
Attachment #8593697 - Flags: review?(amarchesini)
MSVC 7 is no longer supported, so this can now be an nsRefPtr.
Attachment #8593716 - Flags: review?(amarchesini)
Attachment #8593716 - Flags: review?(amarchesini) → review+
Duplicate of this bug: 1126019
https://hg.mozilla.org/mozilla-central/rev/81b5aeceab76
https://hg.mozilla.org/mozilla-central/rev/d77021666bb0
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.