Firefox-37.0.1 hangs on big pages with lots of animated GIFs

RESOLVED DUPLICATE of bug 1150089

Status

()

Core
ImageLib
--
critical
RESOLVED DUPLICATE of bug 1150089
3 years ago
3 years ago

People

(Reporter: Dmitry, Unassigned)

Tracking

({hang})

37 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150417032156

Steps to reproduce:

Forefox-37.0.1 Hangs on big pages with lots of animated gifs

Big pages  with lots of animated gifs (Google+, for example) cause Firefox-37.0.1 to hang on Linux and stop render animations on Windows.

Steps to reproduce:
1. Open https://plus.google.com/s/cat%20gifs
2. Just hold End button and wait.
3. After some time (less than a minute for me) Firefox will stop render gif animations, animations just stops in a middle, or not even showed up
3.windows. New animations and images not showing up on screen
3.linux. New animations and images not showing up on screen. Firefox icons also sometimes disappears (not all of them). Settings window won't open. Browser often completely hangs at this point (without cpu activity). Sometimes it is just exits.

Tested on Gentoo amd64 (compiled from sources), firefox-bin (official binary package on Gentoo) and on Windows Vista, all with official Nvidia drivers.


Actual results:

New images not draw on screen, animations stops, part of browser icons disappears and browser hangs.


Expected results:

Browser should not hangs, at least.

Comment 1

3 years ago
Reproduced hang with 37.0.2.linux64.

Reproduced images ceasing to appear with that and 2015-04-23-03-02-04-mozilla-central-firefox-40.0a1.ru.linux-x86_64.
Keywords: hang

Updated

3 years ago
OS: Linux → Unspecified

Comment 2

3 years ago
This seems to be a duplicate of bug 1155332.
It should probably be marked as a duplicate.

Updated

3 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core

Updated

3 years ago
Severity: normal → critical
OS: Unspecified → Linux
Summary: Forefox-37.0.1 hangs on big pages with lots of animated gifs → Firefox-37.0.1 hangs on big pages with lots of animated GIFs
This is an out-of-memory issue. Duping against bug 1155332.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1155332
Duplicate of bug: 1150089
You need to log in before you can comment on or make changes to this bug.