If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[ja] Update Oshiete-goo searchplugin for Thunderbird

RESOLVED FIXED

Status

Mozilla Localizations
ja / Japanese
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: marsf, Assigned: marsf)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Created attachment 8593769 [details] [diff] [review]
oshiete-goo.xml patch for Tb

Same with Bug 1155529.

Oshiete-goo (教えて!goo) site was renewed in January 28, and the search url and favicon has been changed.
http://help.goo.ne.jp/help/article/2141/

This patch is for Thunderbird.

Comment 1

3 years ago
Please don't forget to ask for review for patches
https://developer.mozilla.org/en/docs/Getting_your_patch_in_the_tree#Getting_the_patch_reviewed

However, there's no mail/searchplugins/google-jp.xml in the source tree, not even a mail/searchplugins directory - http://mxr.mozilla.org/comm-central/source/mail/
(Assignee)

Comment 2

3 years ago
Comment on attachment 8593769 [details] [diff] [review]
oshiete-goo.xml patch for Tb

[Approval Request Comment]
Regression caused by (bug #): none
User impact if declined: Web search for Oshiete-goo doesn't work. 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): no risks
String changes made by this patch: This is ja locale specific change.

Same patch for Firefox has been landed on Bug 1155531.
Attachment #8593769 - Flags: review?(mkmelin+mozilla)
Attachment #8593769 - Flags: approval-comm-beta?
Attachment #8593769 - Flags: approval-comm-aurora?
(Assignee)

Comment 3

3 years ago
(In reply to Magnus Melin from comment #1)
> However, there's no mail/searchplugins/google-jp.xml in the source tree, not
> even a mail/searchplugins directory -
> http://mxr.mozilla.org/comm-central/source/mail/

This is ja locale specific patch. Sorry for my less explanations.
It doesn't affect to en-US or other locales.

http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja/file/c2ec6d14646b/mail/searchplugins
Assignee: nobody → chimantaea_mirabilis

Comment 4

3 years ago
Comment on attachment 8593769 [details] [diff] [review]
oshiete-goo.xml patch for Tb

Review of attachment 8593769 [details] [diff] [review]:
-----------------------------------------------------------------

Ah, I see. 

But since this is [ja] only it's not for me to review or approve, but for the Japanese localization team to decide if and where you want to land it.

::: mail/searchplugins/oshiete-goo.xml
@@ +11,4 @@
>    <Param name="MT" value="{searchTerms}"/>
>  <!--
>    <Param name="from" value="Firefox30"/>
>    <Param name="PT" value="Firefox30"/>

[^^^ sounds old, and this is thunderbird]
Attachment #8593769 - Flags: review?(mkmelin+mozilla)
Attachment #8593769 - Flags: approval-comm-beta?
Attachment #8593769 - Flags: approval-comm-aurora?
(Assignee)

Comment 5

3 years ago
Comment on attachment 8593769 [details] [diff] [review]
oshiete-goo.xml patch for Tb

OK. However, searchplugins are required to review any changes.
Philipp, can you review it for Thunderbird searchplugins?
Attachment #8593769 - Flags: review?(philipp)
(In reply to Magnus Melin from comment #4)
> But since this is [ja] only it's not for me to review or approve, but for
> the Japanese localization team to decide if and where you want to land it.

Productization changes must be review. For Firefox and Fennec that would be on me, for Thunderbird I think :fallen is the right person.

Side note: I agree that those params are probably not relevant for Thunderbird.
Comment on attachment 8593769 [details] [diff] [review]
oshiete-goo.xml patch for Tb

Review of attachment 8593769 [details] [diff] [review]:
-----------------------------------------------------------------

r=philipp

::: mail/searchplugins/oshiete-goo.xml
@@ +11,4 @@
>    <Param name="MT" value="{searchTerms}"/>
>  <!--
>    <Param name="from" value="Firefox30"/>
>    <Param name="PT" value="Firefox30"/>

Luckily its commented out. Not really related to this issue, but I'd suggest removing these commented out parameters.
Attachment #8593769 - Flags: review?(philipp) → review+
(Assignee)

Comment 8

3 years ago
Pushed with removing the commented out parameters.
Thank you.

aurora (ja/ja-JP-mac):
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja/rev/cafa6e3dea5c
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja-JP-mac/rev/afb497ced814

beta (ja/ja-JP-mac):
http://hg.mozilla.org/releases/l10n/mozilla-beta/ja/rev/1a0b282d9350
http://hg.mozilla.org/releases/l10n/mozilla-beta/ja-JP-mac/rev/5074d44dbf01
(Assignee)

Comment 9

3 years ago
http://hg.mozilla.org/l10n-central/ja/rev/d39155bcaa46
http://hg.mozilla.org/l10n-central/ja-JP-mac/rev/ff5629ff2d30
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.