Closed Bug 1155590 Opened 5 years ago Closed 5 years ago

[Settings]We can't disable call forwarding after we delete the number.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S11 (1may)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: huayu.li, Assigned: arthurcc)

Details

(Keywords: regression, Whiteboard: [v2.2-nexus-5-l])

Attachments

(6 files)

Attached file logcat1.txt
[1.Description]:
[Nexus5 2.2&3.0][Flame2.2&3.0]Set a number as call forward number, If we delete this number and then disable forwarding, it will failed.
Occurence time:5:04
See attachment:logcat1.txt,VIDEO0524.MP4

[2.Testing Steps]: 
1.Launch setting.
2.Tap call settings.
3.Tap call Forwarding.
4.Tap one option, ex: Forward when busy.
5.Set a number A and enable forward and then tap OK.
6.After set it successfully, enter the same page, ex:Always forward.
7.Delete the number A.
8.Disable forward and then tap OK.
9.After it prompts that "you've set successfully" or "the phone number is invalid",(There is different prompt message in CMCC and China unicom) , enter the same page, ex: Forward when busy.

[3.Expected Result]: 
9.We should be able to disable the forwarding after deleting phone number.

[4.Actual Result]: 
9.You can see the forward is enabled.

[5.Reproduction build]: 
Device: Flame 2.2[Affected]
Flame 2.2:
Build ID               20150416162504
Gaia Revision          d50b8a3919a7b4d8d289f150d3b9bed704ebafa9
Gaia Date              2015-04-16 21:46:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5ebf32030512
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150416.195720
Firmware Date          Thu Apr 16 19:57:29 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0[Affected]
Build ID               20150416160206
Gaia Revision          3cd0a9facce26c2acc7be3755a17131a6358e33f
Gaia Date              2015-04-16 16:33:22
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/51e3cb11a258
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150416.191700
Firmware Date          Thu Apr 16 19:17:10 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2[Affected]
Build ID               20150416162504
Gaia Revision          d50b8a3919a7b4d8d289f150d3b9bed704ebafa9
Gaia Date              2015-04-16 21:46:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5ebf32030512
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150416.201018
Firmware Date          Thu Apr 16 20:10:32 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0[Affected]
Build ID               20150416160206
Gaia Revision          3cd0a9facce26c2acc7be3755a17131a6358e33f
Gaia Date              2015-04-16 16:33:22
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/51e3cb11a258
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150416.192355
Firmware Date          Thu Apr 16 19:24:11 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video VIDEO0524.MP4
Attached image 2015-04-20-09-24-00.png
2 issues here.
(1) Empty screen without message.
(2) Setting is not successful. 
I tried CHT, TWM & VIBO sims.
Hi Wesley, Could we check the log first and see what do we do, thank you.
Flags: needinfo?(whuang)
Attached file 2.2.log
[Blocking Requested - why for this release]: regression, functionality broken
blocking-b2g: --- → 2.2?
Keywords: regression
I believe it works before, so very likely it's regression. 
Nominated as it looks really bad.

Forwarding the NI to Howie, for checking why the UI reacted unexpectedly.
Flags: needinfo?(whuang) → needinfo?(hochang)
Hi Arthur, please check on this, thanks.
Flags: needinfo?(hochang) → needinfo?(arthur.chen)
Okay, I'll check the issue.
Flags: needinfo?(arthur.chen)
QA Contact: arthur.chen
Triage: blocking
Assignee: nobody → arthur.chen
blocking-b2g: 2.2? → 2.2+
I can only reproduce this on v2.2. The root cause is that l10n on v2.2 does not support setting an l10n id on an element with child elements. This is being fixed on master. Eric, could you help confirm whether this is reproducible on master? Thanks.
Flags: needinfo?(echang)
QA Contact: arthur.chen
Comment on attachment 8595293 [details] [review]
[gaia] crh0716:1155590_v2.2 > mozilla-b2g:v2.2

The root cause is when we disable call forwarding, l10n tries to set a l10n id on an element containing bdi elements and leads the error. The patch removes all child elements before settings the l10n id. EJ, could you help review the patch? Thanks.
Attachment #8595293 - Flags: review?(ejchen)
Comment on attachment 8595293 [details] [review]
[gaia] crh0716:1155590_v2.2 > mozilla-b2g:v2.2

Great, this patch looks nice and let's fix l10n problem for 2.2 in this way !
(In reply to Arthur Chen [:arthurcc] from comment #10)
> I can only reproduce this on v2.2. The root cause is that l10n on v2.2 does
> not support setting an l10n id on an element with child elements. This is
> being fixed on master. Eric, could you help confirm whether this is
> reproducible on master? Thanks.

I can reproduce that with today's build (following steps in comment #0)
Build ID               20150421160203
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/86725d1a2cf3
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.192130
Firmware Date          Tue Apr 21 19:21:42 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(echang)
Comment on attachment 8595765 [details] [review]
[gaia] crh0716:1155590 > mozilla-b2g:master

It seems there are actually two bugs in the description. The l10n one can only be reproduced on v2.2. The other one I believe that it has been existing from the very beginning. Currently we check the validity of the phone number no matter we are enabling or disabling call forwarding, but the phone number gets omitted in the disabling case so there is no need to check it.

EJ, the patch does the phone number check only when in the enabling case. Would you mind review it when you get a chance? Thanks.
Attachment #8595765 - Flags: review?(ejchen)
Comment on attachment 8595293 [details] [review]
[gaia] crh0716:1155590_v2.2 > mozilla-b2g:v2.2

Based on comment 15, the change should also be made on v2.2. Request a review again for that part.
Attachment #8595293 - Flags: review+ → review?(ejchen)
I thought the behavior was by design at first xD !

Let's just follow your patch and add one more check here, and also, i will note on my call settings refactor bug to make sure this change would be addressed there.

Thanks Arthur.
Thanks, EJ!

master: 1de64c55ff5cef4a1a7331f9d611da77687704e8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8595293 [details] [review]
[gaia] crh0716:1155590_v2.2 > mozilla-b2g:v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Users are not able to disable call forwarding if they clear the phone number before disabling.
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): Low. Only adds an additional check and a cleanup on elements before setting the new l10n id.
[String changes made]: None
Attachment #8595293 - Flags: approval-gaia-v2.2?
Attachment #8595293 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue has been successfully verified on flame2.2, flame3.0, Nexus5_2.2, Nexus5_3.0
Reproduction Frequency: 0/5

Device:N5_2.2[Verified]
Build ID               20150428002500
Gaia Revision          9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gaia Date              2015-04-27 20:41:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e79c19bf19bf
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150428.041949
Firmware Date          Tue Apr 28 04:20:07 EDT 2015
Bootloader             HHZ12f

Device:N5 3.0[Verified]
Build ID               20150428010206
Gaia Revision          0636405f0844bf32451a375b2d61a2b16fe33348
Gaia Date              2015-04-27 16:42:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/caf25344f73e
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150428.043749
Firmware Date          Tue Apr 28 04:38:06 EDT 2015
Bootloader             HHZ12f

Device:Flame 2.2[Verified]
Build ID               20150428002500
Gaia Revision          9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gaia Date              2015-04-27 20:41:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e79c19bf19bf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150428.042318
Firmware Date          Tue Apr 28 04:23:30 EDT 2015
Bootloader             L1TC000118D0

Device:Flame 3.0[Verified]
Build ID               20150428010206
Gaia Revision          0636405f0844bf32451a375b2d61a2b16fe33348
Gaia Date              2015-04-27 16:42:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/caf25344f73e
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150428.043926
Firmware Date          Tue Apr 28 04:39:37 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.