[Flame][Settings] It will display another page,if you launch the same app again and again.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: yi.zou, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8593858 [details]
logcat_1404.txt

[1.Description]:
[Flame v2.2 & v3.0][Settings]Launch Settings app, and enters a sub menu, like Sound. Then tap home button to back to homescreen. Launch Settings and back to homescreen again and again. You will find device returns to Settings view.
Time:14:04
See attachment logcat_1404.txt and 1404.mp4


[2.Testing Steps]: 
1.Launch Settings app.
2.Tap home button back to homescreen.
3.Repeat  step1 to step2 again and again.

[3.Expected Result]: 
3.It will display the same view.

[4.Actual Result]: 
3.It will not display the same view.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150416162504
Gaia Revision          d50b8a3919a7b4d8d289f150d3b9bed704ebafa9
Gaia Date              2015-04-16 21:46:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5ebf32030512
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150416.195720
Firmware Date          Thu Apr 16 19:57:29 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150416160206
Gaia Revision          3cd0a9facce26c2acc7be3755a17131a6358e33f
Gaia Date              2015-04-16 16:33:22
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/51e3cb11a258
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150416.191700
Firmware Date          Thu Apr 16 19:17:10 EDT 2015

N5 2.2 version(Unaffected):
Build ID               20150416162504
Gaia Revision          d50b8a3919a7b4d8d289f150d3b9bed704ebafa9
Gaia Date              2015-04-16 21:46:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5ebf32030512
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150416.201018
Firmware Date          Thu Apr 16 20:10:32 EDT 2015
Bootloader             HHZ12f

N5 3.0 version(Unaffected):
Build ID               20150416160206
Gaia Revision          3cd0a9facce26c2acc7be3755a17131a6358e33f
Gaia Date              2015-04-16 16:33:22
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/51e3cb11a258
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150416.192355
Firmware Date          Thu Apr 16 19:24:11 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
occasionally Recurrence,6/10

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
(Reporter)

Comment 1

4 years ago
Created attachment 8593859 [details]
1404.mp4
Hi Zouyi,  I was not able to reproduce that but is there any other apps opened in the background? Is that reproducible in other sub menu?
Flags: needinfo?(yi.zou)
(In reply to Eric Chang [:ericcc] [:echang] from comment #2)
> Hi Zouyi,  I was not able to reproduce that but is there any other apps
> opened in the background? Is that reproducible in other sub menu?

Hi Eric,

The bug can't reproduced in latest Flame 2.2 & Nexus 5-2.2 & Nexus 5-3.0, but it still exists in Flame 3.0. And it still exist in other sub menu. It's not important that any app opens in the background or not.

See attachment: 1602.mp4

Flame 2.2 & Nexus 5-2.2 & Nexus 5-3.0:
Fail rate:0/30

Flame 3.0:
Fail rate:2/5

Device: Flame 2.2 version(Pass):
Build ID               20150420002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150420.041634
Firmware Date          Mon Apr 20 04:16:45 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 version(Fail):
Build ID               20150420160201
Gaia Revision          a8e4f95dce9db727dda5d408b038f97fb4296557
Gaia Date              2015-04-20 19:30:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e7112314d9d5
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150420.191858
Firmware Date          Mon Apr 20 19:19:10 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 version(Pass):
Build ID               20150420002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150420.042319
Firmware Date          Mon Apr 20 04:23:35 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5_3.0 version(Pass):
Build ID               20150416160206
Gaia Revision          3cd0a9facce26c2acc7be3755a17131a6358e33f
Gaia Date              2015-04-16 16:33:22
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/51e3cb11a258
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150416.192355
Firmware Date          Thu Apr 16 19:24:11 EDT 2015
Bootloader             HHZ12f
Flags: needinfo?(yi.zou) → needinfo?(echang)
Flags: needinfo?(echang) → needinfo?(hcheng)
I cannot reproduce on Flame-kk master. Maybe it was fixed in other bug.

Could you try again?
Flags: needinfo?(hcheng) → needinfo?(liuke)
(In reply to Hermes Cheng[:hermescheng] from comment #5)
> I cannot reproduce on Flame-kk master. Maybe it was fixed in other bug.
> 
> Could you try again?

Hi Hermes,

According to the video in comment 1, this bug still exists on today's nightly build of Flame v3.0.

Steps:
1.Launch Settings app.
2.Then tap any option(ex:wifi/call settings).
3.Press home button back to homescreen.
4.Repeat  step1 to step2 again and again.

Actual Result: 
4.It will display the Settings main view.

Fail rate:3/5
See attachment:0045.3gp and logcat_0045.txt
Found time:00:45

Device: Flame 3.0(319m)(Fail):
Build ID               20150610160207
Gaia Revision          e3eaf72ccd1bfe6d60d37efde6d3b92c1dbc5ff9
Gaia Date              2015-06-10 03:13:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/95afddf894e3
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150610.193636
Firmware Date          Wed Jun 10 19:36:48 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(liuke) → needinfo?(hcheng)
Created attachment 8620844 [details]
logcat_0045.txt
Its reproduce rate seems very very low. I only had once and then I can't reproduce anymore.
This might be a window management problem but not settings.
Component: Gaia::Settings → Gaia::System::Window Mgmt
Flags: needinfo?(hcheng)
(Reporter)

Comment 10

3 years ago
This bug can not be repro on latest builds of Flame KK v2.5&master 512mb, so I close this bug, if anyone can repro it, please reopen it again.

Occurrence rate: 0/10

Device: Flame KK v2.5 512mb(Unaffected)
Build ID               20151211164817
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ded0306e0d78528cdcb237c8b05543390f10ec96
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151211.160256
Firmware Date          Fri Dec 11 16:03:05 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK Master 512mb(Unaffected)
Build ID               20151213030223
Gaia Revision          d886e152b42e557db612470d3417fe2947cbdeee
Gaia Date              2015-12-10 21:39:23
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f07e71078bc8991f74c2101944c8f869c77f442a
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151213.064610
Firmware Date          Sun Dec 13 06:46:23 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.