Closed Bug 1155606 Opened 6 years ago Closed 6 years ago

[e10s] F1398665248 Flash crash while the mozilla thread is in PluginInstanceChild::ShowPluginFrame()

Categories

(Core :: Plug-ins, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1158561

People

(Reporter: jimm, Unassigned)

Details

https://crash-stats.mozilla.com/report/index/ae51ac1a-fa0a-4dee-b866-0bef12150413#allthreads

0 	ntdll.dll 	KiFastSystemCallRet 	
1 	ntdll.dll 	NtWaitForMultipleObjects 	
2 	KERNELBASE.dll 	GetTickCount 	
3 	user32.dll 	RealMsgWaitForMultipleObjectsEx 	
4 	user32.dll 	RealMsgWaitForMultipleObjectsEx 	
5 	xul.dll 	mozilla::ipc::MessageChannel::WaitForSyncNotify() 	ipc/glue/WindowsMessageLoop.cpp
6 	xul.dll 	mozilla::ipc::MessageChannel::Send(IPC::Message*, IPC::Message*) 	ipc/glue/MessageChannel.cpp
7 	xul.dll 	mozilla::plugins::PPluginInstanceChild::SendShow(_NPRect const&, mozilla::plugins::SurfaceDescriptor const&, mozilla::plugins::SurfaceDescriptor*) 	obj-firefox/ipc/ipdl/PPluginInstanceChild.cpp
8 	xul.dll 	mozilla::plugins::PluginInstanceChild::ShowPluginFrame() 	dom/plugins/ipc/PluginInstanceChild.cpp
9 	xul.dll 	mozilla::plugins::PluginInstanceChild::InvalidateRectDelayed() 	dom/plugins/ipc/PluginInstanceChild.cpp
10 	xul.dll 	MessageLoop::DoWork() 	ipc/chromium/src/base/message_loop.cc
11 	xul.dll 	base::MessagePumpForUI::DoRunLoop() 	ipc/chromium/src/base/message_pump_win.cc
12 	xul.dll 	base::MessagePumpWin::RunWithDispatcher(base::MessagePump::Delegate*, base::MessagePumpWin::Dispatcher*) 	ipc/chromium/src/base/message_pump_win.cc
13 	xul.dll 	base::MessagePumpWin::Run(base::MessagePump::Delegate*) 	ipc/chromium/src/base/message_pump_win.h
14 	xul.dll 	MessageLoop::RunInternal() 	ipc/chromium/src/base/message_loop.cc
15 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
16 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
17 	xul.dll 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp
18 	plugin-container.exe 	content_process_main(int, char** const) 	ipc/contentproc/plugin-container.cpp
19 	plugin-container.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
20 	plugin-container.exe 	__tmainCRTStartup 	f:/dd/vctools/crt/crtw32/startup/crt0.c
Summary: [e10s] F1398665248 crash in Flash while mozilla's thread is in PluginInstanceChild::ShowPluginFrame() → [e10s] F1398665248 Flash crash while the mozilla thread is in PluginInstanceChild::ShowPluginFrame()
Jim can you reproduce this or are you filing it from crash-stats? If you have STR I'd love to see if we can debug both this process as well as the other Flash processes, since I think the problem is likely in one of the Flash processes.

This is reported as a plugin crash, but is it possible that this is a hang that's getting misreported?
Flags: needinfo?(jmathies)
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> Jim can you reproduce this or are you filing it from crash-stats? If you
> have STR I'd love to see if we can debug both this process as well as the
> other Flash processes, since I think the problem is likely in one of the
> Flash processes.
> 
> This is reported as a plugin crash, but is it possible that this is a hang
> that's getting misreported?

Unfortunately I found this and filed off crash-stats.

We just got plugin crash submission working again so I'm going to be digging into these for e10s over the next few weeks. I'll look into issues with the hang detector. Quickly poking at it we don't appear to be tagging plugin processes from the new hang monitor... I'll file a bug on that once I confirm.
Flags: needinfo?(jmathies)
(In reply to Jim Mathies [:jimm] from comment #2)
> (In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> > Jim can you reproduce this or are you filing it from crash-stats? If you
> > have STR I'd love to see if we can debug both this process as well as the
> > other Flash processes, since I think the problem is likely in one of the
> > Flash processes.
> > 
> > This is reported as a plugin crash, but is it possible that this is a hang
> > that's getting misreported?
> 
> Unfortunately I found this and filed off crash-stats.
> 
> We just got plugin crash submission working again so I'm going to be digging
> into these for e10s over the next few weeks. I'll look into issues with the
> hang detector. Quickly poking at it we don't appear to be tagging plugin
> processes from the new hang monitor... I'll file a bug on that once I
> confirm.

We still tag with the same annotation - 

https://crash-stats.mozilla.com/search/?product=Firefox&version=40.0a1&plugin_hang=__true__&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-signature
Unless you have more specifics, I recommend duping this against the generic bug for this signature, bug 774281.
Blocks: e10s-hangs
No longer blocks: F1398665248
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1158561
No longer blocks: e10s-hangs
Crash Signature: [@ F1398665248_____________________________ ]
tracking-e10s: - → ---
You need to log in before you can comment on or make changes to this bug.