Windows XP showing several tiny icons per toolbar button when using Luna Silver with high DPI

RESOLVED FIXED in Firefox 40

Status

()

Firefox
Theme
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Gijs, Assigned: dao)

Tracking

({regression})

40 Branch
Firefox 40
x86_64
Windows XP
regression
Points:
1
Bug Flags:
firefox-backlog +
in-testsuite -
qe-verify -

Firefox Tracking Flags

(firefox40 fixed)

Details

Attachments

(2 attachments)

Created attachment 8593936 [details]
weird-xp-icons.PNG

Dao, any ideas on how I can debug this? This reproduces on a clean profile for me in my XP vm...
Flags: qe-verify-
Flags: needinfo?
Flags: in-testsuite-
Flags: firefox-backlog+
Now with correct needinfo...
Flags: needinfo? → needinfo?(dao)
Version: 35 Branch → 40 Branch
(Assignee)

Comment 2

3 years ago
That's with increased DPI? Looks like we're using the image regions for Toolbar@2x.png but Toolbar-lunaSilver.png as the image.
Blocks: 1147702
Flags: needinfo?(dao)
Keywords: regressionwindow-wanted
Summary: Windows XP showing several tiny icons per toolbar button on current nightly → Windows XP showing several tiny icons per toolbar button when using Luna Silver with high DPI
(Assignee)

Comment 3

3 years ago
Created attachment 8594295 [details] [diff] [review]
possible patch

Does this help?
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #8594295 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8594295 [details] [diff] [review]
possible patch

Review of attachment 8594295 [details] [diff] [review]:
-----------------------------------------------------------------

Yup, that helps. Thanks!
Attachment #8594295 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Updated

3 years ago
Iteration: --- → 40.2 - 27 Apr
Points: --- → 1
https://hg.mozilla.org/mozilla-central/rev/a787c9daa1b9
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
You need to log in before you can comment on or make changes to this bug.