ENTER key functions incorrectly

VERIFIED DUPLICATE of bug 111723

Status

()

VERIFIED DUPLICATE of bug 111723
17 years ago
17 years ago

People

(Reporter: skeese, Assigned: aaronlev)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.6+)
Gecko/20011206
BuildID:    2001120608

ENTER key inserts a left arrow, perhaps symbolizing a carriage return, when it
should funtion like the RETURN key.  This happens on all pages where keystrokes
are entered and there is a GO, OK, ACCEPT, or similar button.  For example, the
URL entry line at the top of the window, the  ID and password entry fields of
logon pages, data entry pages of any type. 
The key ENTER should be mapped to the same function as the RETURN key on these
pages.  It is in fact the more appropriate key to replace the Enter button click
than the RETURN key.

Reproducible: Always
Steps to Reproduce:
1.Use any data entry field.  The URL entry field at the top of the window works
fine.
2.Enter some text.
3.Press the ENTER key (not the RETURN key)

Actual Results:  You get http://www.mozilla for example, with a left arrow at
the end.

Expected Results:  There would be no arrow and the browser would respond as if I
had clicked on the GO, OK, SEARCH, or ENTER button, as it does when I press the
RETURN key.

I'm using a Powerbook G4 with OS 10.1 and Mozilla 0.9.6.  I believe this problem
has been around in all previous builds.

*** This bug has been marked as a duplicate of 111723 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.