Disable vsync rendering on lollipop devices on b2g 2.2

RESOLVED FIXED in 2.2 S11 (1may)

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mchang, Assigned: mchang)

Tracking

unspecified
2.2 S11 (1may)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master disabled)

Details

Attachments

(1 attachment)

Due to hardware vsync issues on Nexus 5 Lollipop, including on L 5.1, disable hardware vsync rendering on b2g 2.2. Right now the compositor is using the hardware vsync thread, but trying to enable and initialize the vsync thread during manual testing is unreliable. It can cause all 4 CPUs on the hardware to disable and shut off. It can also force us into a condition where we display two vsync notifications: 1 on the hardware thread and 1 on the software vsync thread, wasting CPU usage. Disable all vsync rendering on L devices until the hardware composer is fixed.
Assignee

Updated

4 years ago
Assignee: nobody → mchang
Attachment #8594093 - Flags: review?(bugmail.mozilla)
Comment on attachment 8594093 [details] [diff] [review]
Disable vsync rendering on 2.2

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Project Silk
User impact if declined: CPUs may be disabled which will cause the phone to become unusable. Wasted battery life, random bugs such as no rendering at all.
Testing completed: Manual
Risk to taking this patch (and alternatives if risky): Low, this reverts silk and should use the old rendering paths on L devices on 2.2
String or UUID changes made by this patch: None
Attachment #8594093 - Flags: approval-mozilla-b2g37?
Attachment #8594093 - Flags: review?(bugmail.mozilla) → review+
Assignee

Updated

4 years ago
Blocks: 1155797
blocking-b2g: --- → 2.2+
Mason, Is the plan to get this preffed on for 2.2 once the hardware composer issues are fixed?
Flags: needinfo?(mchang)
(In reply to bhavana bajaj [:bajaj] from comment #3)
> Mason, Is the plan to get this preffed on for 2.2 once the hardware composer
> issues are fixed?

It will stay preffed on for kit-kat as there aren't any hardware composer issues. If the L vsync fixes aren't risky, we can try to turn this on for L, but I don't have any strong plans to flip this on for 2.2, especially because it's a high risk change and late in the release.
Flags: needinfo?(mchang)
Hedging the bets a bit, but the bottom line is, for every day that we don't have the QC fix in hand, we reduce the chance of flipping this on last minute.  The change is small on our side, so it's just a question of getting that fix early and being able to test enough.
Attachment #8594093 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
(In reply to Milan Sreckovic [:milan] from comment #5)
> Hedging the bets a bit, but the bottom line is, for every day that we don't
> have the QC fix in hand, we reduce the chance of flipping this on last
> minute.  The change is small on our side, so it's just a question of getting
> that fix early and being able to test enough.

Thanks, I'll follow-up on the HWC side.
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/fe97574cd27d
Status: NEW → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S11 (1may)
You need to log in before you can comment on or make changes to this bug.