Closed Bug 1155833 Opened 6 years ago Closed 6 years ago

generate_bmo_data.pl broken with Cannot add or update a child row: a foreign key constraint fails (`bugs`.`products`, CONSTRAINT `fk_products_default_op_sys_id_op_sys_id`

Categories

(bugzilla.mozilla.org :: Developer Box, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: gps, Assigned: dkl)

Details

generate_bmo_data.pl appeared to break in the past week or so.

Creating initial dummy product 'TestProduct'...
Creating group can_configure_antispam...
Adding a new user setting called 'product_chooser'
Adding a new user setting called 'headers_in_body'
Adding a new user setting called 'ui_experiments'
Creating group no-github-auth...
Adding a new user setting called 'show_gravatars'
Adding a new user setting called 'show_my_gravatar'
Adding a new user setting called 'inline_history'
Adding a new user setting called 'block_needinfo'
Adding a new user setting called 'orange_factor'
Adding a new user setting called 'request_nagging'
Adding a new user setting called 'block_reviews'
creating user accounts...
creating classifications...
creating products...
DBD::mysql::db do failed: Cannot add or update a child row: a foreign key constraint fails (`bugs`.`products`, CONSTRAINT `fk_products_default_op_sys_id_op_sys_id` FOREIGN KEY (`default_op_sys_id`) REFERENCES `op_sys` (`id`) ON DELETE SET NULL ON UPDATE CASCADE) [for Statement "INSERT INTO products (name, description, classification_id) VALUES (?, ?, ?)"] at /var/lib/bugzilla/bugzilla/contrib/docker/generate_bmo_data.pl line 307.
Regression range is 7b7e0cc4000fa15305a8f76f580b3a2dd22a04ee..a6f7795a0460db0ad1ef0ffcfb7e3725c0e0fd7f.
bug 579089 introduces a new fk with a default value of 'Unspecified'.  checksetup will create these values if required (see https://git.mozilla.org/?p=webtools/bmo/bugzilla.git;a=commitdiff;h=e9bfbbb [github])

because it works behind bugzilla's back, generate_bmo_data will need to be updated to follow suit.
Component: General → Developer Box
Assignee: nobody → dkl
Status: NEW → ASSIGNED
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   58cccce..4aa44c4  master -> master
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.