[Window Management] Unable to dismiss keyboard on SIM PIN dialog in landscape mode

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8594149 [details]
logcat_20150417_SIMPINDialogLandscape.txt

Description:
When the SIM PIN dialog appears in landscape mode, the user is unable to see the input field as it is completely covered by the number keypad. The user is unable to dismiss the keypad.

Pre-requisite: Have a SIM with PIN enabled.

Repro Steps:
1) Update a Flame to 20150417010203.
2) Open Browser, and set the device in landscape mode.
3) Pull down the notification tray, and enable airplane mode.
4) Disable airplane mode.
5) Observe the SIM PIN dialog.

Actual:
It is impossible to see the input field in the landscape mode since the keypad would not get dismissed.

Expected:
The user is able to see the input field and check how many digits are entered.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150417010203
Gaia: 3cd0a9facce26c2acc7be3755a17131a6358e33f
Gecko: 51e3cb11a258
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 5/5
See attached: video clip, logcat
https://youtu.be/qKnfm1alJo4
(Reporter)

Comment 1

3 years ago
This issue also reproduces on Flame 2.2.

Result: It is impossible to see the input field in the landscape mode since the keypad would not get dismissed.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150417002504
Gaia: d50b8a3919a7b4d8d289f150d3b9bed704ebafa9
Gecko: 5ebf32030512
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

===============================================

This issue does NOT reproduce on Flame 2.1.

Result: The keypad gets dismissed when the user taps the "Enter SIM 1 PIN" area.

Environmental Variables:
Device: Flame 2.1 (KK, 319mb, full flash)
Build ID: 20150417001203
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: c54aa1be51d6
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This is a bad regression so nominating this 2.2? The user cannot see what they are typing and cannot dismiss the keyboard.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
QA Contact: ychung
(Reporter)

Comment 3

3 years ago
*** CORRECTION ***

This issue DOES reproduce on Flame 2.2.

Result: The keypad gets dismissed when the user taps the "Enter SIM 1 PIN" area.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150417002504
Gaia: d50b8a3919a7b4d8d289f150d3b9bed704ebafa9
Gecko: 5ebf32030512
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Sorry about the confusion, and I will continue on finding the regression window.
status-b2g-v2.2: affected → unaffected
(Reporter)

Comment 4

3 years ago
I cannot reproduce this bug any longer. Closing the bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: ychung
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

3 years ago
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.