Closed Bug 1155887 Opened 9 years ago Closed 9 years ago

[NFC][2.2] Cannot initiate transfer request

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 affected, b2g-master unaffected)

RESOLVED DUPLICATE of bug 1152117
Tracking Status
b2g-v2.2 --- affected
b2g-master --- unaffected

People

(Reporter: onelson, Unassigned)

References

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Description:
Flame devices on 2.2 are unable to perform NFC transfer. Devices with NFC enabled are pushed back to back (to initiate transfer): 'swipe to share' doesn't appear, no vibrate or indicitation that devices are communicating. Attempted from gallery and music to no avail. Attempted to disable/enable NFC as well as restart devices.

PreReq:
* enable NFC on two devices
Repro Steps:
1) Update a Flame to 20150417002504
2) Open gallery on one device
3) Open a single image in large view
4) Place phones back to back to initiate NFC transfer

Actual:
Phones do not initiate NFC transfer

Expected:
Phones begin NFC transfer request


Environmental Variables:
Device: Flame 2.2
Build ID: 20150417002504
Gaia: d50b8a3919a7b4d8d289f150d3b9bed704ebafa9
Gecko: 5ebf32030512
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency: 5/5
See attached: 
logcat ( doesn't appear to have generated any results when NFC was supposed to begin _
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [2.2-Daily-Testing]
NI on component owner to take a look, this is worse than bug 1152117.

Nominating for 2.2, broken feature.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(ashiue)
Whiteboard: [2.2-Daily-Testing] → [3.0-Daily-Testing]
Although I can transfer file via NFC with v2.2 build, I think this issue is duplicate of bug 1152117 that sometimes NFC could not work, you can always let NFC work after turn off and turn on devices screen.
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(ashiue)
Resolution: --- → DUPLICATE
already dup, remove nom
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.