Closed Bug 1155911 Opened 7 years ago Closed 6 years ago

[tab queue] Opening external links can cause two nightly apps in task switcher

Categories

(Firefox for Android Graveyard :: General, defect)

40 Branch
Other
Android
defect
Not set
normal

Tracking

(firefox41 fixed, fennecNightly+)

RESOLVED FIXED
Firefox 41
Tracking Status
firefox41 --- fixed
fennec Nightly+ ---

People

(Reporter: kats, Assigned: mhaigh)

References

Details

Attachments

(1 file)

1. Launch fennec using a home screen bookmark
2. Switch to another app (e.g. gmail app on android) and click a link. Choose option to open it in Firefox if prompted
3. Go to android task switcher

Expected:
Fennec is there only once

Actual:
Fennec shows up twice. Switching the other fennec opens a new tab with the external link. You can repeat this indefinitely, always switching to the "other" fennec. Only way to get rid of it seems to be to kill fennec entirely which is pretty bad.

100% reproducible for me on nightly on a nexus 4. It might affect other channels too; today was the first time I've done this particular sequence of steps so not sure if it's a recent regression.
Whoever ends up looking at this: check which task affinity we set for our home screen icons, 'cos that's probably the culprit or quite close to it.
This sounds like Android's poor task switching been an OS issue for a long time http://www.androidpolice.com/2012/09/18/ux-things-i-hate-about-android/ "The Recent Apps List Gets Confused" section sounds like this.
Assignee: nobody → mhaigh
liuche mentions trying android:excludeFromRecents="true" in bug 1156563 comment 0.
Summary: Opening external links can cause two nightly apps in task switcher → [tab queue] Opening external links can cause two nightly apps in task switcher
I have seen this (mentioned it to snorp a few days ago) and I think it is a recent regression. Note that I see it on my Galaxy S5, but not my Nexus 5. Kats what device are you seeing it on?
A Nexus 4 running Android 4.2.2
N7 (2013 wifi) running 5.1 and can't reproduce.  Also can't reproduce on my N6 running 5.1 -> perhaps a 4.x issue?
The reason for this is based around the Tab Queue work - the dispatcher is being seen as an extra process which is showing up in the recents list.  It has the same label as BrowserApp so it appears that Fennec itself is showing, but if you press on the second instance of Fennec in the recents list, the toast reappears.

Adding exludeFromRecents=true to the TabQueueDispatcher means that we remove the extra entry in recents menu.  Unfortunately this has a knock on effect that on Android L it will stop the main browser window from appearing in the recents list, so we add a taskAffinity to the Service to ensure that the Tab Queue code is in a separate task to the rest of Fennec.
Attachment #8603390 - Flags: review?(rnewman)
Blocks: tab-queue
Comment on attachment 8603390 [details] [diff] [review]
Opening external links can cause two nightly apps in task switcher

Review of attachment 8603390 [details] [diff] [review]:
-----------------------------------------------------------------

This seems sane to me (testing will decide!), but is there any reason why TabQueueDispatcher isn't in the same task?
Attachment #8603390 - Flags: review?(rnewman) → review+
Putting TabQueueDispatcher in the same task doesn't do anything as it's a short lived process with no UI, either it calls out to BrowserApp or TabQueueService, both of which now define their own taskAffinity.
https://hg.mozilla.org/mozilla-central/rev/2401d8d37f57
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Blocks: 1166062
Using Nighly+ and Fixed to track features that should not get uplifted.
tracking-fennec: --- → Nightly+
No longer blocks: 1166062
Doesn't this affect 40 as well? Or did the original feature (that introduced the regression) not ride the train to aurora?
We'd rather have two icons in the tab switcher than zero, so I'm going to back this out to resolve Bug 1165856.
Tree is closed, and I think I found the root cause. Over to Bug 1165856
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.