Persistent loading spinner after loading ogg audio in onunload

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Kris, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8594254 [details]
Minimal test case to reproduce the ogg onunload bug

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36

Steps to reproduce:

In the body onload= handler, create an <audio> element and append an ogg audio file as a <source> child element that is not already in the browser cache. Navigate away from the page either by clicking a link or typing a URL into the address bar and pressing enter.


Actual results:

The loading spinner next to the page title in the browser tab and a "Waiting for <ogg file's domain>" toast in the bottom-left corner will persist indefinitely.

Issue can be reproduced in:
Windows 7 Firefox 35.0
Mac OS X Firefox 36.0
Linux Firefox 37.0


Expected results:

The new page should finish loading without being affected by the previous page.

Comment 1

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build Id: 20151216175450

I tried to reproduce the issue with the minimal test case provided. In Firefox 43, the page loads after 10 seconds. This, also happens on Firefox 46 (Nightly).
Component: Untriaged → Audio/Video
Product: Firefox → Core

Comment 2

2 years ago
If someone thinks this is not the right component, please fell free to change it to a more appropriate one. Thanks.
Appears fixed - in 45 it delays for ~ 10 seconds and then times out; either clicking a link or browsing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.