Opening again a pop-up in private mode redirects to the pop-up in normal mode and doesn't open a new one in private mode

RESOLVED DUPLICATE of bug 1100154

Status

()

Firefox
Private Browsing
RESOLVED DUPLICATE of bug 1100154
2 years ago
a year ago

People

(Reporter: Marco, Unassigned)

Tracking

40 Branch
x86
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150417030200

Steps to reproduce:

I have opened the samsung website at contact page http://www.samsung.com/it/info/contactus.html and pressed chat "Avvia una chat" a new window with a module is loaded.

Now i have opened a new private window and loaded this page http://www.samsung.com/it/info/contactus.html pressed "Inviaci un messaggio" for leave a message and is not opened a nwe private pop up but the previolus one opened in not protected way is edited .. so i loose the chat module and see now contact page


Actual results:

Protect mode is not isolated. In some case if i open a pop up from normal mode than i open protect private mode and press the same link who open pop up is not open a new private pop up but is edited the previous one


Expected results:

should open a different private pop up
(Reporter)

Comment 1

2 years ago
Version ESR affected, Version Nighty 40 affected I think also 38, 39

Comment 2

2 years ago
Created attachment 8594329 [details]
private-popup.jpg

I'm still in private mode with FF40 and the pop-up open.

Comment 3

2 years ago
Ok, I see what you mean. If the pop-up is open in normal mode, calling it again in private mode redirects to the pop-up in normal mode and doesn't open a new one in private mode.
Component: Untriaged → Private Browsing

Updated

2 years ago
Summary: Private Window issue open not private window → Opening again a pop-up in private mode redirects to the pop-up in normal mode and doesn't open a new one in private mode
(Reporter)

Comment 4

2 years ago
Yes correct. Tou are right Loic
(Reporter)

Comment 5

2 years ago
Also the live chat not work with Firefox but this maybe is a live chat problem of the new chat Samsung. You are put in queue and when operator accept the chat (I have tested with Firefox ESR 31.6.0)when you wrote in the input box input is slow, many letters you digit is lost and not printed in the inbox field so little impossible to chat with Firefox. Here I don't know if is Firefox issue or Live Chat issue.

For this i will not open a bug report. For now I want only alert of the problem in the private mode and pop up as Loic has explained.

Opening again a pop-up in private mode redirects to the pop-up in normal mode and doesn't open a new one in private mode
(Reporter)

Comment 6

a year ago
CAN BE THIS CLOSED?

Comment 7

a year ago
(In reply to Marco from comment #6)
> CAN BE THIS CLOSED?

Is it fixed in 45?
(Reporter)

Comment 8

a year ago
Don't know because the website Samsung where I had see the issue is changed.
So I don't know anymore how to reproduce.

Comment 9

a year ago
I think it's a dupe of bug 1100154.
(Reporter)

Comment 10

a year ago
I try to close for now
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1100154
You need to log in before you can comment on or make changes to this bug.