build fails in history with --disable-mail-news

VERIFIED DUPLICATE of bug 11405

Status

SeaMonkey
Build Config
P3
normal
VERIFIED DUPLICATE of bug 11405
19 years ago
13 years ago

People

(Reporter: Akhil Arora, Assigned: Scott MacGregor)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Today's pull failed with the following error. Looks like nsGlobalHistory is not
protected with something like #ifdef mail-news-enabled. The compiler is
egcs-2.91.66.

gmake[4]: Leaving directory `/opt/mozilla-tip/xpfe/components/history/public'
cd src; gmake libs
gmake[4]: Entering directory `/opt/mozilla-tip/xpfe/components/history/src'
c++ -o nsGlobalHistory.o -c   -fno-rtti -fno-exceptions -include
../../../../config-defs.h -g  -fPIC  -DDEBUG -UNDEBUG -DDEBUG_akhilk -DTRACING
-DOSTYPE=\"SunOS5\" -DNECKO  -I../../../../dist/include
-I../../../../dist/./include -I../../../../dist/include -I../../../../include
-I../../../../dist/./public/jpeg -I../../../../dist/./public/png
-I../../../../dist/./public/zlib    nsGlobalHistory.cpp
In file included from nsGlobalHistory.cpp:53:
nsMdbPtr.h:31: mdb.h: No such file or directory
nsGlobalHistory.cpp:55: nsMorkCID.h: No such file or directory
nsGlobalHistory.cpp:56: nsIMdbFactoryFactory.h: No such file or directory
nsGlobalHistory.cpp:57: mdb.h: No such file or directory
gmake[4]: *** [nsGlobalHistory.o] Error 1
gmake[4]: Leaving directory `/opt/mozilla-tip/xpfe/components/history/src'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/opt/mozilla-tip/xpfe/components/history'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/opt/mozilla-tip/xpfe/components'
gmake[1]: *** [libs] Error 2
gmake[1]: Leaving directory `/opt/mozilla-tip/xpfe'
gmake: *** [libs] Error 2


my ~/.mozconfig looks like this -

ac_add_options --disable-dtd-debug
ac_add_options --disable-editor
ac_add_options --disable-mailnews
ac_add_options --disable-tests
ac_add_options --disable-single-signon
ac_add_options --disable-md
ac_add_options --disable-static
ac_add_options --with-pthreads

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 1

19 years ago
This is a known problem, and will be resolved soon.  The story I've heard
is that mdb.h will be moved out of mailnews, or perhaps that the non-mailnews
specific portions of it will be placed in a new header file outside of the
mailnews directory.  I don't know the timeframe, but I'm hoping this will
happen before M9 is released.

Comment 2

19 years ago
Reassigning this to Scott, since he owns the equivalent Windows
bug.
Assignee: briano → mscott
Status: ASSIGNED → NEW

Updated

19 years ago
Target Milestone: M10

Comment 3

19 years ago
The bug is 11405 and the plan isn't to do this until M10.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
Marking as a dup.

*** This bug has been marked as a duplicate of 11405 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
verified dup
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.