Setting device under profile preferences doesn't work

VERIFIED FIXED

Status

support.mozilla.org
BuddyUp
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Christos Bacharakis, Assigned: fredy)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Flame 2.0
Github latest commit:2f2c9edc660e8c1a9bd3daa59f974b5cb5d520a3

STR:
1. Launch the Buddy Up app.
2. Tap on the "Gear" button at the right top corner of the screen.
3. Change device preferences to "Flame" or "ZTE"
4. Tap on "Done" button on top right corner.
5. Tap on the "Gear" button again and notice the model is: "All"

Homepage appears.
(Assignee)

Updated

3 years ago
Summary: Setting model under profile preferences doesn't work → Setting device under profile preferences doesn't work

Updated

3 years ago
Keywords: regression, regressionwindow-wanted
I'm not reproducing this on my account. Is it account specific?
Created attachment 8594778 [details] [review]
patch

Deleting whitespaces in the two options seems to solve the issue. Not sure where exactly in code create the issue.
Attachment #8594778 - Flags: review?(anthony)
Comment on attachment 8594778 [details] [review]
patch

Ah very good catch! I didn't pay enough attention to STR 3.

For next bugs, if you notice that a bug only applies in very specific condition, please highlight it. It helps when investigating the issue.
Attachment #8594778 - Flags: review?(anthony) → review+
https://github.com/mozilla/buddyup/commit/fdc2fe14259583f98bf8ae572183c5102b462e22
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Assignee: nobody → fredy
(Assignee)

Updated

3 years ago
Status: RESOLVED → VERIFIED
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.