CPU hang in xul.dll!`anonymous namespace'::CheckMemAvailable+0x2e after Zoom in Google Maps.

RESOLVED INCOMPLETE

Status

()

--
critical
RESOLVED INCOMPLETE
3 years ago
3 years ago

People

(Reporter: tmptgr, Unassigned)

Tracking

({perf})

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8594565 [details]
FirefoxDev_kernel_hang.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

Steps to reproduce:

Zoom in Google Maps.


Actual results:

Blacked out areas, partially painted tab, 100% of one core red (kernel) according to Process Explorer.


Expected results:

Stay responsive.

Comment 1

3 years ago
Does it occur when using an nightly build?
 https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
Can you get a profile?
 https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem
Severity: normal → critical
Flags: needinfo?(tmptgr)
Keywords: perf
Summary: CPU hang in xul.dll!`anonymous namespace'::CheckMemAvailable+0x2e → CPU hang in xul.dll!`anonymous namespace'::CheckMemAvailable+0x2e after Zoom in Google Maps.
(Reporter)

Comment 2

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #1)
> Does it occur when using an nightly build?
>  https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-
> central/
> Can you get a profile?
>  https://developer.mozilla.org/en-US/docs/Mozilla/Performance/
> Reporting_a_Performance_Problem

Some of my favorite add-ons didn't work in the Nightly, but i'll try it again after stable 39 crashes. Here's the last crash of stable 38: https://crash-stats.mozilla.com/report/index/98b1ee45-02ed-42b2-bee0-d14502150702
(Reporter)

Comment 3

3 years ago
Stable 39 crashed without warning and currently just lags my whole system (except IE11) with a stack as such:

wow64.dll!whNtQuerySystemInformation_SystemBasicPerformanceInformation+0x46
wow64.dll!whNtQuerySystemInformation+0x88d
wow64.dll!Wow64SystemServiceEx+0xd7
wow64cpu.dll!TurboDispatchJumpAddressEnd+0x2d
wow64.dll!RunCpuSimulation+0xa
wow64.dll!Wow64LdrpInitialize+0x42a
ntdll.dll!LdrpInitializeProcess+0x17e3
ntdll.dll!??_C@_0BN@KLOBBEB@Enabling?5heap?5debug?5options?6?$AA@FNODOBFM@+0x25b20
ntdll.dll!LdrInitializeThunk+0xe
ntdll.dll!_ZwQuerySystemInformation@16+0x12
ntdll.dll!_RtlNtStatusToDosError@4+0x3b
xul.dll!`anonymous namespace'::CheckMemAvailable+0x2e
xul.dll!`anonymous namespace'::VirtualAllocHook+0x41
mozglue.dll!chunk_alloc_mmap+0x17
mozglue.dll!chunk_alloc+0x32
mozglue.dll!huge_palloc+0x38
mozglue.dll!je_malloc+0x339
xul.dll!PLDHashTable::ChangeTable+0x56
xul.dll!js::gc::MarkObjectSlots+0x80c
xul.dll!js::TraceChildren+0xb4
xul.dll!mozilla::JSGCThingParticipant::Traverse+0x145
xul.dll!CCGraphBuilder::BuildGraph+0x55
xul.dll!nsCycleCollector::MarkRoots+0x1a
xul.dll!nsCycleCollector::Collect+0xb9
xul.dll!nsCycleCollector_collectSlice+0x3d
xul.dll!nsJSContext::RunCycleCollectorSlice+0x19b
xul.dll!nsTimerImpl::Fire+0x1a2
xul.dll!nsTimerEvent::Run+0x37
xul.dll!nsThread::ProcessNextEvent+0x2b2
xul.dll!NS_ProcessNextEvent+0x1a
xul.dll!mozilla::ipc::MessagePump::Run+0xb7
xul.dll!MessageLoop::RunHandler+0x20
xul.dll!MessageLoop::Run+0x19
xul.dll!nsBaseAppShell::Run+0x32
xul.dll!nsAppShell::Run+0x1b
xul.dll!nsAppStartup::Run+0x20
xul.dll!XREMain::XRE_mainRun+0x487
xul.dll!XREMain::XRE_main+0x1b6
xul.dll!XRE_main+0x3e
firefox.exe!do_main+0x125
firefox.exe!NS_internal_main+0xec
firefox.exe!wmain+0xbc
firefox.exe!__tmainCRTStartup+0xfe
kernel32.dll!@BaseThreadInitThunk@12+0xe
ntdll.dll!___RtlUserThreadStart@8+0x70
ntdll.dll!__RtlUserThreadStart@8+0x1b

It's not responding, so I can't get the crash link. Here's another stack:

ntdll.dll!ZwQueryInformationProcess+0xa
wow64.dll!whNtQueryInformationProcess_SpecialQueryCase+0x125
wow64.dll!whNtQueryInformationProcess+0x12b
wow64.dll!Wow64SystemServiceEx+0xd7
wow64cpu.dll!TurboDispatchJumpAddressEnd+0x2d
wow64.dll!RunCpuSimulation+0xa
wow64.dll!Wow64LdrpInitialize+0x42a
ntdll.dll!LdrpInitializeProcess+0x17e3
ntdll.dll!??_C@_0BN@KLOBBEB@Enabling?5heap?5debug?5options?6?$AA@FNODOBFM@+0x25b20
ntdll.dll!LdrInitializeThunk+0xe
ntdll.dll!_ZwQueryInformationProcess@20+0x12
xul.dll!`anonymous namespace'::CheckMemAvailable+0x2e
mozglue.dll!chunk_alloc_mmap+0x17
mozglue.dll!chunk_alloc+0x32
mozglue.dll!huge_palloc+0x38
mozglue.dll!je_malloc+0x339
xul.dll!PLDHashTable::ChangeTable+0x56
xul.dll!js::TraceChildren+0x12f5
xul.dll!js::gc::Mark<js::ObjectGroup>+0x499
xul.dll!js::TraceChildren+0x35
xul.dll!mozilla::JSGCThingParticipant::Traverse+0x145
xul.dll!CCGraphBuilder::BuildGraph+0x55
xul.dll!nsCycleCollector::MarkRoots+0x1a
xul.dll!nsCycleCollector::Collect+0xb9
xul.dll!nsCycleCollector_collectSlice+0x3d
xul.dll!nsJSContext::RunCycleCollectorSlice+0x19b
xul.dll!nsTimerImpl::Fire+0x1a2
xul.dll!nsTimerEvent::Run+0x37
xul.dll!nsThread::ProcessNextEvent+0x2b2
xul.dll!NS_ProcessNextEvent+0x1a
xul.dll!mozilla::ipc::MessagePump::Run+0xb7
xul.dll!MessageLoop::RunHandler+0x20
xul.dll!MessageLoop::Run+0x19
xul.dll!nsBaseAppShell::Run+0x32
xul.dll!nsAppShell::Run+0x1b
xul.dll!nsAppStartup::Run+0x20
xul.dll!XREMain::XRE_mainRun+0x487
xul.dll!XREMain::XRE_main+0x1b6
xul.dll!XRE_main+0x3e
firefox.exe!do_main+0x125
firefox.exe!NS_internal_main+0xec
firefox.exe!wmain+0xbc
firefox.exe!__tmainCRTStartup+0xfe
kernel32.dll!@BaseThreadInitThunk@12+0xe
ntdll.dll!___RtlUserThreadStart@8+0x70
ntdll.dll!__RtlUserThreadStart@8+0x1b

39.0.0.5659 stable. Process Explorer system stats: CPU Usage 45.51%, Commit Charge 80.91%, Processes 101, Physical Usage 77.16%.
Flags: needinfo?(tmptgr)
(Reporter)

Comment 4

3 years ago
(In reply to Cees T. from comment #3)
> It's not responding, so I can't get the crash link.

Looks like it sent some hangs as well, as I don't remember it crashing that much:

bp-e9775480-b403-4f60-8957-0c6542150705
	5-7-2015	15:13
00fb4eef-3033-4db7-bceb-99c3e88f658f
	5-7-2015	13:50
bp-87da642c-3b18-4666-82b9-7d56b2150704
	4-7-2015	23:10
bp-3fb269e7-8b1f-4a42-86be-5dd1b2150704
	4-7-2015	17:16
bp-db47f5cf-6f09-4881-82e1-e7b742150704
	4-7-2015	14:30
bp-98b1ee45-02ed-42b2-bee0-d14502150702
	2-7-2015	23:09

I should get some work done today, so have no time to experiment with a Nightly.
(Reporter)

Comment 5

3 years ago
Created attachment 8638918 [details]
Firefox 40 beta freezes.txt

I think the update window said beta 7, but i can't find that anymore. Anyway, that appears to have fixed this hang/crash but introduced a new one.
Cees T. are you still experiencing the hangs/crashes on the latest Firefox versions (Firefox 43, Nightly 46)?
https://www.mozilla.org/en-US/firefox/new/
https://nightly.mozilla.org/

Comment 7

3 years ago
unclear wither the issues cited in comment 4 are relevant to this bug. That said, most of those signatures have recently resolved bugs
bug 1177278 RESOLVED FIXED Large OOMs in CacheFileMetadata::WriteMetadata
bug 1171724 RESOLVED FIXED Large OOMs in CacheFileMetadata
bug 1029671 RESOLVED FIXED Large OOM in jArray<T>::newJArray with NoScript & Session Manager add-on

Cees T. hasn't replied, so => incomplete
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(tmptgr)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.