RFE: Message, Label: Additional Search option



MailNews: Message Display
17 years ago
14 years ago


(Reporter: Thommie Rother, Assigned: Scott MacGregor)


Windows 2000

Firefox Tracking Flags

(Not tracked)



(1 attachment)

5.65 KB, patch
Navin Gupta
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review


17 years ago
The really GREAT "coloured labels" options should be enhanced: It should be
possible to search for a particular flag throughout the whole profile. The best
solution would be something like a "virtual folder" which contains one type of


17 years ago
Ever confirmed: true
QA Contact: esther → laurel
Summary: Message, Label: Additional Search option → RFE: Message, Label: Additional Search option

Comment 1

16 years ago
reassigning to ssu.
Assignee: sspitzer → ssu
Target Milestone: --- → Future

Comment 2

16 years ago
Re-tested on build 20020328. THis RFE is critical for making the labels really
useful. Nominating for mozilla1.0

Comment 3

16 years ago
*** Bug 138085 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
Related concept:  Bug 139484 (rfe: add label counts to optional folder pane
columns) proposes to optionally identify at a glance in which folders there are
messages labeled important, todo, etc.

Comment 5

16 years ago
*** Bug 151170 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
marking this a duplicate of newer bug since mscott is taking it on... see bug

*** This bug has been marked as a duplicate of 162563 ***
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
Undoing duplicate resolution since mscott stated he just put in the backend
plumbing for this... leaving this open for UI part.
Resolution: DUPLICATE → ---
right, this bug is about adding the UI to the advanced message search UI to 
take advantage of the BE work that scott's doing for #162563 
Depends on: 162563

Comment 9

16 years ago
I have a fix for this. I need it for something I'm working on. 
Assignee: ssu → mscott
Severity: enhancement → normal
Target Milestone: Future → ---

Comment 10

16 years ago
Created attachment 100776 [details] [diff] [review]
the fix (exposes label searching in the UI for local searches)

Comment 11

16 years ago
Comment on attachment 100776 [details] [diff] [review]
the fix (exposes label searching in the UI for local searches)

Attachment #100776 - Flags: review+
Comment on attachment 100776 [details] [diff] [review]
the fix (exposes label searching in the UI for local searches)


+var gLabelStrings = new Array;; 

remove the extra ;

is this something we'll have to fork rules.dat for, or are we ok?

(see that the SenderInAddressBook is commented out.)
Attachment #100776 - Flags: superreview+

Comment 13

16 years ago
I think this was added recently so it should not be checked in until we checkin
that forking rules.dat. 

const nsMsgSearchAttribValue SenderInAddressBook = 47;

107 mscott   1.16     const nsMsgSearchAttribValue Label = 48; /* mail
only...can search by label */


Comment 14

16 years ago
We don't have to worry about waiting for the data fork on rules.dat. You can't
currently filter by lable since labeling is a filter action not a criteria. As
such, no one is writing search queries using labels to disk. Hence, no need to
wait for a fork in filter rules.dat. 

In the case of SenderInAddressbook, that is added as a new filter rule which
effects rules.dat, hence it needs to wait. 

Comment 15

16 years ago
checked in.
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 16

16 years ago
OK using oct14 commercial trunk: win98, linux rh6.2, mac OS 10.1
implemented, basically working, label offered and working as search criteria for
local folders/pop... any further issues noticed will be logged separately.

Comment 17

16 years ago
Basically working, verified for Mozilla 1.2b Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.2b) Gecko/20021024. A note on the implementation: Right now,
label search seems to be restricted to Local Folders and also IMAP/POP, but only
 in offline status. As it is possible to add labels to POP/IMAP msgs in online
mode, it should also be possible to search in this mode, although it may be a
bit tricky to get the search always being done locally ;-) Same for nntp/news:
labels can be added to certain news msgs in offline and onllne mode. But there
is no possibility to search for them ... Well, I don't know how you guys
implemented this and how complicate it may be, it's just a wish for christmas
from me ;-)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.