Make switch from boot animation to first system app screen seamlessly

RESOLVED FIXED in 2.2 S12 (15may)

Status

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: chiajung, Assigned: vliu)

Tracking

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Currently, boot animation is stopped by GLinit or first swap buffer.
However, the powered by mozilla init logo is shown serveral frame later, we want to find the reason and make the switch smoother.
(Reporter)

Updated

4 years ago
Depends on: 1156140
(Assignee)

Comment 1

4 years ago
From dumping the display list, it contains an div element with id:carrier-logo between bootanimation and the powered by mozilla init logo.

I/Gecko   ( 2874):   BackgroundColor p=0xab111410 f=0xb0fe57f0(HTMLScroll(div)(1) id:carrier-logo) bounds(0,0,19200,34160) layerBounds(0,0,19200,34160) visible(0,0,19200,34160) componentAlpha(0,0,0,0) clip(0,0,19200,34160)  uniform (opaque 0,0,19200,34160) (rgba 0,0,0,1) layer=0xa91d1800

A hack to change the attribute of background to make sure we hit the correct element. 

diff --git a/apps/system/style/system/initlogo.css b/apps/system/style/system/initlogo.css
index 56c49c7..a813eae 100644
--- a/apps/system/style/system/initlogo.css
+++ b/apps/system/style/system/initlogo.css
@@ -15,7 +15,7 @@
   overflow: hidden;
   width: 100%;
   height: 100%;
-  background: #000;
+  background: rgba(255, 0, 255, 1);
 }
(Assignee)

Comment 2

4 years ago
Since this attribute set #000 in CSS, it means that even we don't put carrier-logo, gecko still paint this background(#000). This paint behavior causes switching from boot animation to the powered by mozilla init logo doesn't look seamlessly. The better way should remove this attribute in CSS. Once we need this attribute, we can operate it in js.
(Assignee)

Updated

4 years ago
Assignee: nobody → vliu
(Assignee)

Comment 4

4 years ago
Posted file Pull request for bug-1156141-fix (obsolete) —
Hi Vivien,

Based on Comment 2, could you please have a review for the patch? Thanks.
Attachment #8596316 - Flags: review?(21)
(Assignee)

Comment 5

4 years ago
Hi Alive,

As discussed, could you please help me to review it? Thanks.
Attachment #8596316 - Attachment is obsolete: true
Attachment #8596316 - Flags: review?(21)
Attachment #8598399 - Flags: review?(alive)
Comment on attachment 8598399 [details] [review]
Pull request for bug-1156141-fix

r=me
Attachment #8598399 - Flags: review?(alive) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Component: General → Gaia::System
http://docs.taskcluster.net/tools/task-graph-inspector/#zBZc7dMjQrCAwYZgdu0nOA

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Comment 9

4 years ago
(In reply to Autolander from comment #8)
> http://docs.taskcluster.net/tools/task-graph-inspector/
> #zBZc7dMjQrCAwYZgdu0nOA
> 
> The pull request failed to pass integration tests. It could not be landed,
> please try again.

Since I don't see any fail case for integration tests, I would set checkin-needed again.
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#RyGmlW-1S8m4JG44r-f0NA

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Blocks: 1171351
No longer blocks: 1171351
Duplicate of this bug: 1171351
Nominate to "b2g-2.2+". bug 1171351 happens on b2g v2.2.
blocking-b2g: --- → 2.2?
Vincent, please request for uplift approval.
Flags: needinfo?(vliu)
(Assignee)

Comment 15

4 years ago
Comment on attachment 8598399 [details] [review]
Pull request for bug-1156141-fix

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: The screen turns black in short period of time between boot animation and init-logo. 
Testing completed: 
Risk to taking this patch (and alternatives if risky): No risk to take this patch
String or UUID changes made by this patch:
Attachment #8598399 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
Attachment #8598399 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

3 years ago
Flags: needinfo?(vliu)
You need to log in before you can comment on or make changes to this bug.