Closed Bug 1156150 Opened 5 years ago Closed 3 years ago

PresShell::HandleEvent Crash when hovering tooltip in developer tools (e. g. image or font preview)

Categories

(DevTools :: Inspector, defect, P2)

37 Branch
x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1181564

People

(Reporter: sebastian.simon1602, Unassigned)

References

()

Details

(Keywords: crash)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150403142420

Steps to reproduce:

Crash report: https://crash-stats.mozilla.com/report/index/ed9128d0-1bf5-440f-9b70-a8c4f2150420

Firefox 37.0.1 crashed in safe mode as well as with add-ons: in the developer tools in the inspector I tried to look at the CSS rules and hovered with the cursor over a font declaration. Then the tooltip with a preview of the font appeared (with the example sentence “The quick brown fox jumped over the lazy dog”). Whenever I move my mouse over that tooltip, Firefox crashes.

This happens on any website and with any font.

The attached picture shows that tooltip. Whenever I hover my mouse over it, I experience a browser crash.
Component: Untriaged → Developer Tools: Inspector
This happens not only with the font preview but with any of those pop ups (e. g. image previews, etc.).
Summary: PresShell::HandleEvent Crash when hovering font preview tooltip in developer tools → PresShell::HandleEvent Crash when hovering tooltip in developer tools (e. g. image or font preview)
This is making developing kinda unbearable.
Can you explain more precisely what's need to move the mouse onto the tooltip?  

When testing on a font-family tooltip, I have to move the mouse off of the font-family to reach the tooltip, but by then the tooltip has closed itself.  Are you seeing different behavior?
Flags: needinfo?(sebastian.simon1602)
This video demonstrates exactly (as best as possible) how to reproduce the crash.

It mostly happens accidentally when I quickly move the mouse upwards: one of those tooltips opens and my mouse already moved over that tooltip and then the browser crashes.

I’ll experiment with some of my window manager settings. Maybe some of those either cause this crash or make this crash possible (i. e. maybe the tooltip closes more slowly for me than for you, for example).
Flags: needinfo?(sebastian.simon1602)
I just started another Laptop with Ubuntu 14.04 LTS and the same Firefox version and actually couldn’t reproduce this bug (tooltip actually closes too quickly). Not sure whether it still happens in Ubuntu 15.04, I can’t upgrade right now… I couldn’t find any relevant CompizConfig setting, though…
I just upgraded to Firefox 38.0. Still the same situation.
Crash Signature: [@ PresShell::HandleEvent ]
Keywords: crash
After (finally) upgrading to Ubuntu 15.04 I’m unable to reproduce the bug. As far as I can confirm, this issue is specific to Ubuntu 14.10 or has been fixed in Firefox 40 or 41 (which I feel is less likely), was first discovered in Firefox 37 and lasted until at least Firefox 39 (the last version supported in Ubuntu 14.10). Not sure whether to mark this bug as resolved…
Will try to reproduce on Ubuntu 14.10. (ni? myself as reminder)
Inspector bug triage. Filter on CLIMBING SHOES
Flags: needinfo?(jdescottes)
Could you please check described behavior one more time with latest sources (I mean in latest Nightly).
(But before testing turn on w3c_pointer_events and touch_action in about:config and restart browser).
Flags: needinfo?(sebastian.simon1602)
I couldn’t reproduce the bug with the latest Nightly on Ubuntu 15.10. I can’t downgrade or otherwise install Ubuntu 14.10 right now, but I’ll test it again, when I can.
Flags: needinfo?(sebastian.simon1602)
Inspector bug triage (filter on CLIMBING SHOES).
Crash should be a P1, but since we can't reproduce it so far, marking as P2 for now.
Priority: -- → P2
(In reply to Sebastian Simon from comment #10)
> I couldn’t reproduce the bug with the latest Nightly on Ubuntu 15.10. I can’t downgrade 
> or otherwise install Ubuntu 14.10 right now, but I’ll test it again, when I can.
I hope that bug does not related with ubuntu versions.
Did you turn on pointer events preferences before testing at the lastest time?
Flags: needinfo?(sebastian.simon1602)
(In reply to Maksim Lebedev from comment #12)
> Did you turn on pointer events preferences before testing at the lastest
> time?

Yes, I tested it as prescribed in comment #9.
Flags: needinfo?(sebastian.simon1602)
Flags: needinfo?(jdescottes)
Per Comment 10.
Status: UNCONFIRMED → RESOLVED
Crash Signature: [@ PresShell::HandleEvent ]
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1181564
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.