If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Navigator toolbars vanish after entering URL in modern theme

RESOLVED INVALID

Status

Core Graveyard
Skinability
--
major
RESOLVED INVALID
16 years ago
9 years ago

People

(Reporter: Rob Thornton, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.6+) Gecko/20011214
BuildID:    20011214004

After using this build of 0.9.6 and the modern theme for at least three days,
suddenly almost all of the toolbars vanish in every Navigator window when I move
to a new URL. The Navigation toolbar is still there, but the only controls
available are the back, forward, refresh, and stop buttons.

Is this related to bug <A
HREF="http://bugzilla.mozilla.org/showvotes.cgi?bug_id=43350">43350</A>? That
bug concerns the Composer and the Mail components, though.

Reproducible: Always
Steps to Reproduce:
1. Switch themes (?) - not sure about this step but I am using the Modern theme
instead of the classic default....
2. Open Mozilla or create a new Navigator window to create a Navigator window
with all the toolbars 
3. Enter URL into field to the left of "Go" button and press return
4. Toolbars vanish


Actual Results:  Most of the components in the Navigator toolbar vanish (except
the Back, Forward, Refresh, and Stop buttons) and all of the other available
toolbars (Personal, Status and Component) vanish as well.

Expected Results:  The toolbars shouldn't have vanished. I have looked through
the Preferences, and there's no options for minimizing the theme's controls.  To
my knowledge, I have not selected any options that control this.

All of the toolbars, including the Navigation toolbar, can be refreshed by
creating a new navigator window or reinstalling the modern theme, but they
vanish after I enter a new URL.

I can retrieve the Status, Component, and Personal toolbars in an affected
window by using the View>Show/Hide command. In this situation, the Show/Hide
submenu shows those three toolbars as visible (still checked) even though they
vanish after Mozilla moves to a new URL.
(Reporter)

Comment 1

16 years ago
I found a workaround shortly after reporting this bug. 

Since I couldn't use the browser in Modern, I switched back to Classic. When I
switched, the components in the Navigator toolbar was replaced by this button
called "Normal Screen" that I had never seen before. I clicked this button and
all of the components were back where they belonged.

Then I switched back to Modern and all seemed well. To verify, I closed Mozilla
and restarted. The toolbars remained upon restart, even if I switched URLs. 

Could this bug have something to do with a piece of old functionality in
previous Mozilla builds? I remember some sort of "minimize" function in a build
of 0.9.3 or something like that....

Comment 2

16 years ago
You probably hit F11 (Full Screen mode). Marking as wfm.

Comment 3

16 years ago
Using 0.9.7 on Linux, I had the same problem. Pressing F11 does resolve this
issue. The question remains: why does the browser come up with all toolbars
visable, but only after selecting an URL the toolbars disappear as described?

I don't think "full screen mode" should be a setting that is kept after the
browser is restarted.

Comment 4

16 years ago
I don't see it in the recent build, can anyone see this again?

Comment 5

16 years ago
Created attachment 70928 [details]
"Normal screen" replaces toolbars

Comment 6

16 years ago
The Full Screen misbehavior is really a major bug. The attachment shows how
unclear what's going on. One thing that isn't happening is that the "Full
Screen" option in the View menu isn't checked even though the option is selected.

Another problem is that it isn't actually full screen--it just changes the
internals of the window (see attachment).

The third problem is that the initial window created doesn't go into full screen
mode until the url is changed for the first time.

If this can't be fixed, then fullscreen mode for the Mac (is it the same way on
the PC?) should be turned off.

Comment 7

16 years ago
The old fullscreen stuff doesn't exist any more on Mac afaik.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.