[RTL][Notifications]The ellipsis is shown at wrong side of LTR text in new message notification banner.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
P2
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Sue, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8594660 [details]
ellipsis_in_notification_banner.png

[1.Description]:
[RTL][Flame v2.2 & v3.0][Nexus5 v2.2&v3.0][Notifications]The ellipsis is shown at left side of LTR text in notification banner when device receives a message with long LTR text.
See attachment:ellipsis_in_notification_banner.png

[2.Testing Steps]: 
Prerequisite: Insert a SIM card.
1. Set system language as Arabic.
2. Receive a message with long LTR text.
**The notification of new message pops up.
3. Observe the "..." in notification banner.

[3.Expected Result]: 
3. The ellipsis should be shown at right side of LTR text.

[4.Actual Result]: 
3. The ellipsis is shown at left side of LTR text.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040848
Firmware Date          Sun Apr 19 04:08:59 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150419160202
Gaia Revision          c6b04efa0f31a584e6ee0a46dd2b64c1e3c29adc
Gaia Date              2015-04-17 21:10:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a32e3b93c8d8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.193329
Firmware Date          Sun Apr 19 19:33:40 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150419.041307
Firmware Date          Sun Apr 19 04:13:23 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150419160202
Gaia Revision          c6b04efa0f31a584e6ee0a46dd2b64c1e3c29adc
Gaia Date              2015-04-17 21:10:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a32e3b93c8d8
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150419.193737
Firmware Date          Sun Apr 19 19:37:53 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Triage P2. 
Also, I see that Bug 1152230 just landed on 2.2. Could that possibly fix the issue here too? Please verify with a tomorrow with a more recent build. Thanks
Keywords: verifyme
Priority: -- → P2
(Reporter)

Comment 2

3 years ago
(In reply to Delphine Lebédel [:delphine - use need info] from comment #1)
> Triage P2. 
> Also, I see that Bug 1152230 just landed on 2.2. Could that possibly fix the
> issue here too? Please verify with a tomorrow with a more recent build.
> Thanks

I had verified the Bug 1152230 which is fixed on Flame 2.2, but this issue still can be repro.
Keywords: verifyme
Ok thanks. One more thing: did you reboot the phone in Arabic to check? If you switched languages and then tried the STRs, this might be the reason you're seeing this issue.
Anyways, I don't think we need to block on this, but would be good to know the above.
Ok thanks. One more thing: did you reboot the phone in Arabic to check? If you switched languages and then tried the STRs, this might be the reason you're seeing this issue.
Anyways, I don't think we need to block on this, but would be good to know the above.
Flags: needinfo?(lulu.tian)
(Reporter)

Comment 5

3 years ago
(In reply to Delphine Lebédel [:delphine - use need info] from comment #4)
> Ok thanks. One more thing: did you reboot the phone in Arabic to check? If
> you switched languages and then tried the STRs, this might be the reason
> you're seeing this issue.

Yes, I reboot device firstly, and then try the STRs, this issue can be repro.
Flags: needinfo?(lulu.tian)
(Reporter)

Comment 6

3 years ago
Created attachment 8604431 [details]
verify_ellipsis is shown correctly.png

This issue can not be repro on latest build of Flame 2.2/3.0 and Nexus 5 2.2/3.0 by the STRs in comment 0. If anyone can repro it, reopen again.
See attachment:verify_ellipsis is shown correctly.png
Rate:0/3

Device: Flame 2.2 (unaffected)
Build ID               20150511002500
Gaia Revision          528ef60e7cda09ad43478065f5d33bda398fbeb7
Gaia Date              2015-05-08 23:40:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d04cc085cf5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150511.035847
Firmware Date          Mon May 11 03:58:59 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (unaffected)
Build ID               20150511160205
Gaia Revision          6089234ace8b294a8feef064387604bae16254e3
Gaia Date              2015-05-10 13:57:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/502e1a5e722f
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150511.193556
Firmware Date          Mon May 11 19:36:04 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (unaffected)
Build ID               20150511002500
Gaia Revision          528ef60e7cda09ad43478065f5d33bda398fbeb7
Gaia Date              2015-05-08 23:40:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d04cc085cf5
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150511.034716
Firmware Date          Mon May 11 03:47:32 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (unaffected)
Build ID               20150511160205
Gaia Revision          6089234ace8b294a8feef064387604bae16254e3
Gaia Date              2015-05-10 13:57:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/502e1a5e722f
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150511.193757
Firmware Date          Mon May 11 19:38:13 EDT 2015
Bootloader             HHZ12f
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

3 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15559/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.