[Music]When you open music from Download list, the play panel is displayed without "Play/Pause" button.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Music
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: SandKing, Assigned: pdahiya)

Tracking

({regression})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8594666 [details]
Bug log: logcat_1434.txt

[1.Description]:
[Flame][v2.2&3.0][Nexus 5][v2.2&3.0][Music]Play a music from download list,you can see  the play panel without "Play/Pause" button. 
See log: "logcat_1434.txt".
See video:"1434.mp4"
Found Time:14:34

[2.Testing Steps]: 
Premise: There are some music file in Download list.
1. Launch "Settings".
2. Choose "Download" item.
3. Tap one of the music and open it.

[3.Expected Result]: 
3. On the Music panel, Play/Pause button should be displayed.

[4.Actual Result]: 
3. You can see the Music play panel is displayed without  Play/Pause button.

[5.Reproduction build]: 
Flame 2.2(Affected): 
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040848
Firmware Date          Sun Apr 19 04:08:59 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Affected):
Build ID               20150419160202
Gaia Revision          c6b04efa0f31a584e6ee0a46dd2b64c1e3c29adc
Gaia Date              2015-04-17 21:10:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a32e3b93c8d8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.193329
Firmware Date          Sun Apr 19 19:33:40 EDT 2015
Bootloader             L1TC000118D0

Nexus5_2.2(Affected): 
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150419.041307
Firmware Date          Sun Apr 19

Nexus5_3.0(Affected): 
Build ID               20150419160202
Gaia Revision          c6b04efa0f31a584e6ee0a46dd2b64c1e3c29adc
Gaia Date              2015-04-17 21:10:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a32e3b93c8d8
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150419.193737
Firmware Date          Sun Apr 19 19:37:53 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8594667 [details]
Bug video: 1434.MP4
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Created attachment 8595105 [details]
2015-04-20-14-46-19.png
[Blocking Requested - why for this release]: broken functionality
blocking-b2g: --- → 2.2?
status-b2g-v2.1: --- → unaffected
Keywords: regression

Comment 4

3 years ago
adding regression-window-wanted and blocking for regression

Punam: 

Can you do the initial investigation on this one since music devs already have blockers that they are working on?

THanks
Hema
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(pdahiya)
Keywords: regressionwindow-wanted
Punam,

I broke this with a recent patch which removed the entire bower_components/ directory and convereted index.html to use shared/compoents/ instead.  But I forgot that there was also the open.html file to be modified.

The clue here is that the screenshot shows the word "play" instead of the play icon. That tells me that the icon font is not loaded. And sure enough, if I look at open.html, it is still using bower_components/ which does not exist anymore.

Should be a trivial fix to open.html

Sorry everyone for the regression.  Removing regression window wanted from the whiteboard.
Keywords: regressionwindow-wanted
(Assignee)

Updated

3 years ago
Assignee: nobody → pdahiya
Flags: needinfo?(pdahiya)
Created attachment 8596152 [details] [review]
[gaia] punamdahiya:Bug1156214 > mozilla-b2g:master
(Assignee)

Comment 7

3 years ago
Comment on attachment 8596152 [details] [review]
[gaia] punamdahiya:Bug1156214 > mozilla-b2g:master

Hi David

Please review attached patch that updates open.html to use shared elements components. Thanks!
Attachment #8596152 - Flags: review?(dflanagan)
Comment on attachment 8596152 [details] [review]
[gaia] punamdahiya:Bug1156214 > mozilla-b2g:master

Thanks Punam. This looks good to me. I did not test, but assume that you have verified that this fixes the bug.
Attachment #8596152 - Flags: review?(dflanagan) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

3 years ago
Thanks David for review. I have tested and it fixes the bug.
(Assignee)

Comment 11

3 years ago
Comment on attachment 8596152 [details] [review]
[gaia] punamdahiya:Bug1156214 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):Bug 1154025
[User impact] if declined: Play and Pause button will not show when music app is opened using open activity
[Testing completed]: On master
[Risk to taking this patch] (and alternatives if risky): Very low
[String changes made]:None
Attachment #8596152 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

3 years ago
Keywords: verifyme

Updated

3 years ago
Attachment #8596152 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/b838d0e7c163e66660dcb6e387d8339944a7a30e
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S11 (1may)
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2&3.0 and Nexus5 v2.2&3.0.

Actual results:From Download list,open the song, Play/Pause button of music is displayed.
See attachment: verified_v2.2&3.0.mp4
Reproduce rate: 0/5

------------------------------------------------------------------------------------------------
Device: Flame 2.2 build(Pass)
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035703
Firmware Date          Thu Apr 23 03:57:16 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Pass)
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.193607
Firmware Date          Thu Apr 23 19:36:18 EDT 2015
Bootloader             L1TC000118D0

Device:Nexus5_v2.2 build(Pass)
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.035409
Firmware Date          Thu Apr 23 03:54:27 EDT 2015
Bootloader             HHZ12f

Device:Nexus5_v3.0 build(Pass)
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.192918
Firmware Date          Thu Apr 23 19:29:36 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Keywords: verifyme
Created attachment 8597219 [details]
verified_v2.2&3.0.mp4
You need to log in before you can comment on or make changes to this bug.