Closed Bug 1156268 Opened 6 years ago Closed 6 years ago

Tabs are not restored after guest session

Categories

(Firefox for Android Graveyard :: Profile Handling, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox40 verified)

VERIFIED FIXED
Firefox 40
Tracking Status
firefox40 --- verified

People

(Reporter: cos_flaviu, Assigned: snorp)

Details

(Keywords: regression)

Attachments

(1 file)

Environment: 
Device: Asus Transformer Tab (Android 4.2.1);
Build: Nightly 40.0a1 (2015-04-19);

Steps to reproduce:
1. Launch Fennec;
2. Load a few pages in different tabs;
3. Tap on Menu -> Tools -> New Guest Session;
4. Tap on Menu -> Tools -> Exit Guest Session;
5. Verify that the tabs opened at step 2 are restored.

Expected result:
The tabs opened in step 2 are correctly restored.

Actual result:
None of the tabs from step 2 are restored; Only the about:home tab is displayed. 

Regression window:
Last good build: 2015-04-18;
First Bad build: 2015-04-19;
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8af644c9b616&tochange=a32e3b93c8d8
Keywords: regression
I see bug 1152308 in the range and it seems to be rewriting the restart code.

Flaviu - can you test mozilla-inbound before/after that bug landed?
From IRC,

[10:30:23] snorp: oh
[10:30:29] snorp: or we're missing the didRestart intent extra
[10:30:31] snorp: that seems most likely
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Attachment #8595404 - Flags: review?(nchen) → review+
Assignee: nchen → snorp
https://hg.mozilla.org/mozilla-central/rev/2798bdbedfb7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Verified as fixed in build 40.0a1 2015-04-22;
Device: Asus Transformer Tab (Android 4.2.1);
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.