Closed Bug 1156393 Opened 7 years ago Closed 7 years ago

2.7% WinXP tp5o_scroll regression on Mozilla-Inbound-Non-PGO (v. 40) on April 20, 2015 from push 84304d9d0082

Categories

(Testing :: Talos, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(firefox40 fixed)

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: vaibhav1994, Assigned: mstange)

References

Details

Attachments

(1 file)

Talos has detected a Firefox performance regression from your commit 84304d9d0082.  We need you to address this regression.

This is a list of all known regressions and improvements related to your bug:
http://alertmanager.allizom.org:8080/alerts.html?rev=84304d9d0082&showAll=1

On the page above you can see Talos alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test, please see: https://wiki.mozilla.org/Buildbot/Talos/Tests#tp5o_scroll

Reproducing and debugging the regression:
If you would like to re-run this Talos test on a potential fix, use try with the following syntax:
try: -b o -p win32 -u none -t g1  # add "mozharness: --spsProfile" to generate profile data

To run the test locally and do a more in-depth investigation, first set up a local Talos environment:
https://wiki.mozilla.org/Buildbot/Talos/Running#Running_locally_-_Source_Code

Then run the following command from the directory where you set up Talos:
talos --develop -e <path>/firefox -a tp5o_scroll

Making a decision:
As the patch author we need your feedback to help us handle this regression.
*** Please let us know your plans by Thursday, or the offending patch will be backed out! ***

Our wiki page oulines the common responses and expectations:
https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=84304d9d0082 has two commits. Dmitry, Markus Stange could you look and see if your patch is causing the regression?
Flags: needinfo?(mstange)
Flags: needinfo?(dimas_000)
Bug 1154676 is not at fault.
Assignee: nobody → mstange
Blocks: 1156129
Status: NEW → ASSIGNED
No longer depends on: 1154676, 1156129
Flags: needinfo?(mstange)
Flags: needinfo?(dimas_000)
Retriggered a bunch of times, and the graph makes it very clear that the changeset indeed caused a regression: http://mzl.la/1zD9bpz
The subtest breakdown shows that it's not one specific subtest that regressed, but all of the pages regressed rather uniformly: http://bit.ly/1E37UNY
Attached patch patchSplinter Review
Caching the bounds seems to fix it.
Attachment #8595675 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/4a1bcd249152
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
I am sorry guys I am a bit late because of other works and activities...
It looks like the question has been resolved.
Anyway fix for [Bug 1154676](https://bugzilla.mozilla.org/show_bug.cgi?id=1154676) cannot be the reason of performance regression. The fix is just check on null pointer before call of method and no more. And it affects MAC OS(Cocoa) branch only.
You need to log in before you can comment on or make changes to this bug.