Closed Bug 1156445 Opened 7 years ago Closed 7 years ago

Ensure the device display is turned on when running python marionette

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: njpark, Assigned: njpark)

References

Details

Attachments

(2 files, 1 obsolete file)

Currently when the phone bootup takes too much time, the phone would turn off the display while booting up.  We need to add a check to see whether the screen is on before executing the test.
Assignee: nobody → npark
See Also: → 1155817
Attachment #8594941 - Flags: review?(gmealer)
Attachment #8594941 - Flags: review?(dave.hunt)
Component: Marionette → Gaia::UI Tests
Product: Testing → Firefox OS
Comment on attachment 8594941 [details] [review]
[gaia] npark-mozilla:1156445 > mozilla-b2g:master

Copied from GH: Should be fine. Checking if it's locked leaves you on system frame as a side effect, but I don't think that's a problem here. 

LGTM, pending test results.
Attachment #8594941 - Flags: review?(gmealer) → review+
Comment on attachment 8594941 [details] [review]
[gaia] npark-mozilla:1156445 > mozilla-b2g:master

See comment in pull request.
Attachment #8594941 - Flags: review?(dave.hunt) → review-
Summary: Add check to see the device display is turned on → Ensure the device display is turned on when running python marionette
Comment on attachment 8594941 [details] [review]
[gaia] npark-mozilla:1156445 > mozilla-b2g:master

changes made
Attachment #8594941 - Flags: review- → review?(dave.hunt)
Comment on attachment 8594941 [details] [review]
[gaia] npark-mozilla:1156445 > mozilla-b2g:master

I don't like that the screen will flick off/on for each test, but can't think of a better alternative. Let's go with this for now.
Attachment #8594941 - Flags: review?(dave.hunt) → review+
We can remove this workaround once the bug 1155817 is resolved.

merged:
https://github.com/mozilla-b2g/gaia/commit/1d14ddcb6db4523dd1b4262890ba676a452fa515
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Reverted for Gij errors as seen on the gaia-try run: https://github.com/mozilla-b2g/gaia/commit/4177209b1ef02325c2c7ac1778c77f55449dfe53

Please consider using checkin-needed and autolander in the future to avoid this problem - It will refuse to land if there are test failures.
Status: RESOLVED → REOPENED
Flags: needinfo?(npark)
Resolution: FIXED → ---
(In reply to Kevin Grandon :kgrandon from comment #7)
> Reverted for Gij errors as seen on the gaia-try run:
> https://github.com/mozilla-b2g/gaia/commit/
> 4177209b1ef02325c2c7ac1778c77f55449dfe53
> 
> Please consider using checkin-needed and autolander in the future to avoid
> this problem - It will refuse to land if there are test failures.

Hi kgrandon, I think the failures in the Comment 8 are caused by unrelated intermittent faults (some of the failures were notified to QA team), since I just created a new pull request with the same change, and now it's passing without issues.

Pull request link:
https://github.com/mozilla-b2g/gaia/pull/29703

treeherder result:
https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=a938685d3bd13ebecae3fd99137c86aa2b88a375
(There were some retries, but they passed on the next run)

Having said that, I should try to use the checkin-needed keyword.  Not sure what's the proper way to go about this - should the reverted checkin be re-entered, or should I merge the new pull request?
Flags: needinfo?(npark) → needinfo?(kgrandon)
Attachment #8596765 - Attachment is obsolete: true
(In reply to No-Jun Park [:njpark] from comment #11)
> Having said that, I should try to use the checkin-needed keyword.  Not sure
> what's the proper way to go about this - should the reverted checkin be
> re-entered, or should I merge the new pull request?

Hmm, strage as reverting seemed to fix that? Sorry if it was an incorrect backout. You need a review on the attachment for autolander to work, and since you can carry R+ here no problem, I'd say just go ahead and manually land this. (Please squash into a single commit with the bug number before doing so though)
Flags: needinfo?(kgrandon) → needinfo?(npark)
Will do, I just verified that the treeherder results are again indeed good for the exact same changes made in this pull request: (squashed into single commit)
https://github.com/mozilla-b2g/gaia/pull/29703

Merged into master:

https://github.com/mozilla-b2g/gaia/commit/b936f129c7b9c9b3403d1cdc555bcc81a450aef4
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(npark)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.