[Contacts][Merge Duplicates] Duplicate elements do not display on the Contact Detail pop-up.

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], )

Attachments

(6 attachments)

Reporter

Description

4 years ago
Description:
If the user views the details of a contact on the Merge Duplicates screen, they expect to see the elements (phone number, email, etc.) of the contact that are duplicated, but instead are presented with only the contact name.


Repro Steps:
1) Update a Flame to 20150420010204
2) Launch the Contacts app.
3) Create a contact with a phone number.
4) Create a second contact with the same phone number
5) At the Merge Duplicates screen, select the presented first contact to view the duplicate elements

Actual:
Duplicate elements are not displayed on the pop up, only the name of the selected contact.

Expected:
The duplicate phone number is displayed below the contact name on the pop up screen.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150420010204
Gaia: cb41d8421da5dc4f16ea566ea2917a9b7f828154
Gecko: 50b95032152c
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 10/10
See attached: Logcat, Video (URL)
Reporter

Comment 1

4 years ago
This issue does NOT occur on Flame 2.2 builds.
The duplicate phone number is displayed below the contact name on the pop up screen.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150420002502
Gaia: c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gecko: cc02ee38b252
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Visible regression of a core feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
The change for Bug 1066347 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150410033337
Gaia: 749b6eb12c103f4119f1f85c72dbe7791684d8dc
Gecko: b99b34dc9bd4
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150410044437
Gaia: 6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Gecko: 5a1b56e833f0
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 749b6eb12c103f4119f1f85c72dbe7791684d8dc
Gecko: 5a1b56e833f0

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Gecko: b99b34dc9bd4

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/749b6eb12c103f4119f1f85c72dbe7791684d8dc...6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
Zibi, can you take a look at this please? Looks like the landing for bug 1066347 might be the culprit here.
Blocks: 1066347
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(gandalf)
The cause of the bug is that communications/contacts/matching_contacts.html is using shared/locales/phone_types/phone_types.properties but does not load it.

As with other bugs around it, it previously worked in CONCAT_LOCALES mode because we were concatenating all resources from all html files from communications app into a single giant ab-CD.json file. Now we create a single json file per .html file and that exposes bugs like this.

It should be fixed by the Contacts team by adding the link to the resource file.
Flags: needinfo?(gandalf)
Attachment #8598490 - Flags: review?(gandalf) → review+
https://github.com/mozilla-b2g/gaia/pull/29764

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Landed:

https://github.com/mozilla-b2g/gaia/commit/2944d188617e3b0b01b6f91156f313d92f76f6cb
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Already landed in 3.0.
blocking-b2g: 3.0? → ---
Posted video v3.0.mp4
Hi,Eric,
This bug has been verified as fail on latest build of Flame v3.0 & Nexus 5 v3.0 by the STR in Comment 0. 
Could you help with this bug?  Thanks!

Results:
There is no duplicate elements displayed on the popup, only the name of the selected contact if we create two contacts with same phone number.

See attachment: v3.0.mp4 & logcat1903.txt
Reproduce rate: 0/15

Device: Flame v3.0(Fail)
Build ID               20150520160208
Gaia Revision          b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gaia Date              2015-05-20 10:19:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8d8df22fe72d
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150520.192608
Firmware Date          Wed May 20 19:26:18 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v3.0(Fail)
Build ID               20150520160208
Gaia Revision          b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gaia Date              2015-05-20 10:19:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8d8df22fe72d
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150520.191346
Firmware Date          Wed May 20 19:14:00 EDT 2015
Bootloader             HHZ12f
Posted file logcat1903.txt
Flags: needinfo?(echang)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+] [MGSEI-Triage+]
Comment on attachment 8608841 [details] [review]
[gaia] zbraniecki:1156468-follow-up > mozilla-b2g:master

I didn't know we require this now, but links to shared files need to be absolute.
Flags: needinfo?(echang)
Attachment #8608841 - Flags: review?(francisco)
Comment on attachment 8608841 [details] [review]
[gaia] zbraniecki:1156468-follow-up > mozilla-b2g:master

Thanks!
Attachment #8608841 - Flags: review?(francisco) → review+
http://docs.taskcluster.net/tools/task-graph-inspector/#3eqhsFY1RiaxbBXHhmAOYA

The pull request failed to pass integration tests. It could not be landed, please try again.

Comment 17

4 years ago
This bug has been verified as pass on latest Nightly build of Flame 3.0 & Nexus 5_3.0 by the STR in Comment 0.
Results:
The duplicate phone number is displayed below the contact name on the pop up screen and highlighted with blue.

See attachment: verify3.0.mp4 
Reproduce rate: 0/15

Device: Flame v3.0(Pass)
Build ID               20150601160204
Gaia Revision          6d477a7884273886605049b20f60af5c1583a150
Gaia Date              2015-06-01 16:41:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/56241c1f8a3b
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150601.193935
Firmware Date          Mon Jun  1 19:39:44 EDT 2015
Bootloader             L1TC000118D0


Device: Nexus 5 v3.0(Pass)
Build ID               20150601075320
Gaia Revision          85e6fcef45c0cb2c017739df42b68b96cf5bb9c3
Gaia Date              2015-06-01 06:40:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/666b584fb521
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150601.112653
Firmware Date          Mon Jun  1 11:27:09 EDT 2015
Bootloader             HHZ12f

Comment 18

4 years ago
Posted video verify3.0.MP4

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.