[Rocketbar] Rocketbar displays app name (ex: 'Clock') instead of 'Search the web' after dynamic language change if app is left open

VERIFIED FIXED in Firefox OS master

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: onelson, Assigned: kgrandon)

Tracking

({verifyme})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)
verifyme

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 affected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8594993 [details]
clock_rocketbar_text.png

Description:
When the user enters the 'Clock' app, they will observe that the 'Search the web' text located in the rocketbar will display 'Clock' instead. This is only observed in clock, other gaia apps display 'Search the web', implying the design for the rocketbar text.

Repro Steps:
1) Update a Flame to 20150420010204
2) Open the 'Clock' app
3) Observe rocketbar text

Actual:
Rocketbar displays text 'Clock' in search bar

Expected:
Rocketbar displays text 'Search the web' in search bar


Environmental Variables:
--------------------------------------------------

Device: Flame 3.0
Build ID: 20150420010204
Gaia: cb41d8421da5dc4f16ea566ea2917a9b7f828154
Gecko: 50b95032152c
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
--------------------------------------------------

Issue DOES NOT REPRO on 2.2 for flame devices:
Results: Rocketbar displays text 'Search the web' in search bar

Device: Flame 2.2
BuildID: 20150420002502
Gaia: c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gecko: cc02ee38b252
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------------

Repro frequency: 5/5
See attached: 
screenshot
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
[Blocking Requested - why for this release]:
Visible regression of a core feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
This issue also reproduces on Flame 2.2 when following the follow STRs:

1. Update a Flame to 20150420002502.
2. Open Clock app.
3. Press the home button, and open Settings.
4. Navigate to the Language settings page, and switch to Arabic.
5. Change the language back to English.
6. Press the home button, and re-open Clock app.
7. Observe the text in the search bar.

Actual: 
"Clock" is displayed.

Expected:
"Search the web" is displayed.

Note:
This issue reproduces on any app with the search bar present at the top. As long as the app remains open during the language change, the name of the app appears in the search bar instead.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150420002502
Gaia: c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gecko: cc02ee38b252
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

===========================
Removing regression keyword.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: unaffected → affected
Flags: needinfo?(pbylenga)
Keywords: regression, regressionwindow-wanted
Since this happens with any app, not just clock, per comment 2, moving this bug to the "Gaia::Search" component which is the only identified home of the rocketbar in https://wiki.mozilla.org/Modules/FirefoxOS.  Updating subject to reflect this.  (Note: not adding myself to cc list.)
Component: Gaia::Clock → Gaia::Search
Summary: [Clock] Rocketbar displays 'Clock' instead of 'Search the web' → [Clock] Rocketbar displays app name (ex: 'Clock') instead of 'Search the web' after dynamic language change if app is left open
Summary: [Clock] Rocketbar displays app name (ex: 'Clock') instead of 'Search the web' after dynamic language change if app is left open → [Rocketbar] Rocketbar displays app name (ex: 'Clock') instead of 'Search the web' after dynamic language change if app is left open
(Assignee)

Comment 4

4 years ago
I'll look at this.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
Created attachment 8595104 [details] [review]
[gaia] KevinGrandon:bug_1156528_app_chrome_name_change_localization > mozilla-b2g:master
(Assignee)

Comment 6

4 years ago
Comment on attachment 8595104 [details] [review]
[gaia] KevinGrandon:bug_1156528_app_chrome_name_change_localization > mozilla-b2g:master

Ben or Etienne - Could either of you guys give this a quick review? We just need to guard the name changed event here in the case we already have a name set. Thanks!
Attachment #8595104 - Flags: review?(etienne)
Attachment #8595104 - Flags: review?(bfrancis)
Comment on attachment 8595104 [details] [review]
[gaia] KevinGrandon:bug_1156528_app_chrome_name_change_localization > mozilla-b2g:master

Makes sense!
Attachment #8595104 - Flags: review?(etienne)
Attachment #8595104 - Flags: review?(bfrancis)
Attachment #8595104 - Flags: review+
(Assignee)

Comment 8

4 years ago
Thanks!
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed
blocking-b2g: 3.0? → 3.0+

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Target Milestone: --- → 2.2 S11 (1may)
status-b2g-master: affected → fixed
This issue is verified fixed on Flame Master.

Result: "Search the web" is displayed properly in the rocketbar.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150430010201
Gaia: db8ea705c0fd1b1684807f5a8e837bb9a36a6f96
Gecko: 4b9b12c248dc
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

==========================
Adding verifyme for 2.2 uplift & verification.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
status-b2g-v2.5: --- → verified
status-b2g-v2.5: verified → ---
You need to log in before you can comment on or make changes to this bug.