B2G doesn't use mozconfig.common.override

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: jld, Assigned: glandium)

Tracking

Trunk
All
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
The top-level mozconfig for B2G builds (for devices or emulators, not B2G Desktop) is default-gecko-config in the gonk-misc project; it includes Gecko's b2g/config/mozconfigs/common (which includes build/mozconfig.common), but not b2g/config/mozconfigs/common.override (-> build/mozconfig.common.override).

This means that a Try run which adds non-default config flags to build/mozconfig.common.override in order to test them will silently fail to affect B2G builds.

As a demonstration, this Try run adds `exit 1` to mozconfig.common.override, which should break all builds but doesn't affect B2G: https://treeherder.mozilla.org/#/jobs?repo=try&revision=fa22b3f35e11
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1175363
(Assignee)

Comment 2

2 years ago
Created attachment 8631947 [details] [review]
Add b2g/config/mozconfigs/common.override to default-gecko-config
Assignee: nobody → mh+mozilla
Attachment #8631947 - Flags: review?(mwu)

Updated

2 years ago
Attachment #8631947 - Flags: review?(mwu) → review+
(Assignee)

Comment 3

2 years ago
Can you merge it?
Flags: needinfo?(mwu)

Comment 4

2 years ago
https://github.com/glandium/gonk-misc/commit/52550d787e275034d98eaa24603c5f2717ca061f
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mwu)
Resolution: --- → FIXED

Comment 5

2 years ago
A better link for the merge - https://github.com/mozilla-b2g/gonk-misc/commit/c490ae41c67f892232599f4ef049467a922b613e
You need to log in before you can comment on or make changes to this bug.