[RTL][Settings]The parentheses are not displayed correctly in Data Settings/ Message Settings/ A-GPS Settings.

RESOLVED DUPLICATE of bug 1218723

Status

Firefox OS
Gaia::Settings
P3
normal
RESOLVED DUPLICATE of bug 1218723
3 years ago
3 years ago

People

(Reporter: Sue, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l], [2.5-rtl-test-run])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8595252 [details]
parentheses.png

[1.Description]:
[RTL][Flame v2.2 & v3.0][Nexus5 2.2 & 3.0][Settings]When user checks Data Settings/ Message Settings/ A-GPS Settings, the parentheses are not displayed correctly.
See attachment:parentheses.png

[2.Testing Steps]: 
Prerequisite: Insert a SIM card.
1. Set system language as Arabic.
2. Launch Settings -> Cellular & Data -> SIM 1 or SIM 2 -> APN Settings.
3. Select Data Settings/ Message Settings/ A-GPS Settings.
4. Observe the parentheses in the view.

[3.Expected Result]: 
4. The parentheses should be located correctly. Such as: " a(b) "

[4.Actual Result]: 
4. The parentheses are not located correctly. Such as: " (a(b " 

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150420002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150420.041634
Firmware Date          Mon Apr 20 04:16:45 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150420160201
Gaia Revision          a8e4f95dce9db727dda5d408b038f97fb4296557
Gaia Date              2015-04-20 19:30:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e7112314d9d5
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150420.191858
Firmware Date          Mon Apr 20 19:19:10 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150420002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150420.042319
Firmware Date          Mon Apr 20 04:23:35 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150420160201
Gaia Revision          a8e4f95dce9db727dda5d408b038f97fb4296557
Gaia Date              2015-04-20 19:30:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e7112314d9d5
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150420.192508
Firmware Date          Mon Apr 20 19:25:24 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Triage -- P3.
Priority: -- → P3
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
This issue can be reproduced on latest build of AriesKK_v2.5
Rate:5/5
Device:AriesKK_v2.5
Build ID               20150811234258
Gaia Revision          c7875bbc8b32e7b95cc55c9690b03b140905d84d
Gaia Date              2015-08-11 18:18:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d4f3a8a75577e4af2914a4e899ca2e724f9715c4
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150811.230622
Firmware Date          Tue Aug 11 23:06:29 UTC 2015
Bootloader             s1
Blocks: 1181943
Created attachment 8647387 [details]
AriesKK_v2.5.png
This issue still can be reproduced on latest AriesKK&FlameKK v2.5 build by the same STR in comment 0.

FlameKK v2.5 build ID (512mb):20151029150245
AriesKK v2.5 build ID: 20151030012032
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l], [2.5-rtl-test-run]

Comment 5

3 years ago
Looks like a Duplicate of bug 1218723 ?
Seems to be fixed by bug 1218723. 

Sue, Alissa or Lancy, don't hesitate to reopen if needed!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1218723
You need to log in before you can comment on or make changes to this bug.