Introduce an API for unloading a tab

RESOLVED DUPLICATE of bug 1128502

Status

()

defect
RESOLVED DUPLICATE of bug 1128502
4 years ago
4 years ago

People

(Reporter: Yoric, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

There are a number of great add-ons that let us unload tabs to save memory usage. I'm not quite sure how they do that, but I'm pretty sure that's at least somewhat hackish/slow.

It would be quite useful to introduce an API for doing this cleanly. Oh, and this would also let us implement bug 1146948.
(I also suspect that there are applications for the upcoming self-help feature)

Updated

4 years ago
No longer blocks: 1146948
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1128502
You need to log in before you can comment on or make changes to this bug.