NSS3.4 build. New web site cert crashes browser.

VERIFIED DUPLICATE of bug 115683

Status

P1
normal
VERIFIED DUPLICATE of bug 115683
17 years ago
2 years ago

People

(Reporter: junruh, Assigned: rangansen)

Tracking

1.0 Branch
psm2.2
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
1.) Click on the above link. Crash.
What is expected. A new web site cert dialog box should appear.

Comment 1

17 years ago
correct summary
cc kai
Priority: -- → P1
Summary: NSS4.3 build. New web site cert crashes browser. → NSS3.4 build. New web site cert crashes browser.
Target Milestone: --- → 2.2

Comment 2

17 years ago
cc relyea

Updated

17 years ago
Blocks: 116334
This seems to be fixed, at least on Linux I don't see a crash.
John, is this fixed in your test windows build?

(Reporter)

Comment 4

17 years ago
It's not entirely fixed. This web site crashes the browser
https://pki.mcom.com/tests.html
This one does not - https://pki.mcom.com:5002
Plus, I filed this bug http://bugzilla.mozilla.org/show_bug.cgi?id=116400
"NSS3.4 build. Web site cert not remembered."
I see the crash at https://pki.mcom.com/tests.html , too. It crashes at the same
location as bug 115683. Stack trace is a bit different:

#0  0x436a0795 in nssTrustDomain_GetCertsForSubjectFromCache (td=0x0,
subject=0x87b36f0, certListOpt=0x87dd2c8) at tdcache.c:770
#1  0x4369f254 in NSSTrustDomain_FindCertificatesBySubject (td=0x0,
subject=0x87b36f0, rvOpt=0x0, maximumOpt=0, arenaOpt=0x0) at trustdomain.c:570
#2  0x4369cb24 in find_issuer_cert_for_identifier (c=0x87b36c0, id=0x87dd298) at
certificate.c:206
#3  0x4369cccd in NSSCertificate_BuildChain (c=0x87b36c0, timeOpt=0x87dd138,
usage=0x4103df24, policiesOpt=0x0, rvOpt=0x4103df18, rvLimit=2, arenaOpt=0x0,
statusOpt=0x4103df14) at certificate.c:277
#4  0x436598b0 in CERT_FindCertIssuer (cert=0x87b4090,
validTime=1008962899935631, usage=certUsageSSLServer) at certvfy.c:419
#5  0x43659fe3 in CERT_VerifyCertChain (handle=0x87ad528, cert=0x87b4090,
checkSig=1, certUsage=certUsageSSLServer, t=1008962899935631, wincx=0x8765590,
log=0x0) at certvfy.c:722
#6  0x4365aca9 in CERT_VerifyCert (handle=0x87ad528, cert=0x87b4090, checkSig=1,
certUsage=certUsageSSLServer, t=1008962899935631, wincx=0x8765590, log=0x0) at
certvfy.c:1157
#7  0x4365ad8e in CERT_VerifyCertNow (handle=0x87ad528, cert=0x87b4090,
checkSig=1, certUsage=certUsageSSLServer, wincx=0x8765590) at certvfy.c:1198
#8  0x436209b8 in SSL_AuthCertificate (arg=0x87ad528, fd=0x8773188, checkSig=1,
isServer=0) at sslauth.c:269
#9  0x4355ce86 in AuthCertificateCallback (client_data=0x0, fd=0x8773188,
checksig=1, isServer=0) at
../../../../../mozilla/security/manager/ssl/src/nsNSSCallbacks.cpp:266
#10 0x4361cda6 in ssl3_HandleCertificate (ss=0x8765230, b=0x87d6c30 "\016",
length=0) at ssl3con.c:6553
#11 0x4361e473 in ssl3_HandleHandshakeMessage (ss=0x8765230, b=0x87d699e "",
length=658) at ssl3con.c:7150
#12 0x4361e87e in ssl3_HandleHandshake (ss=0x8765230, origBuf=0x8765944) at
ssl3con.c:7266
#13 0x4361f08d in ssl3_HandleRecord (ss=0x8765230, cText=0x4103e260,
databuf=0x8765944) at ssl3con.c:7531
#14 0x436201a5 in ssl3_GatherCompleteHandshake (ss=0x8765230, flags=0) at
ssl3gthr.c:204
#15 0x43622e07 in ssl_GatherRecord1stHandshake (ss=0x8765230) at sslcon.c:1300
#16 0x4362acec in ssl_Do1stHandshake (ss=0x8765230) at sslsecur.c:156
#17 0x4362c9ae in ssl_SecureSend (ss=0x8765230, buf=0x8741388 "GET /tests.html
HTTP/1.1\r\nHost: pki.mcom.com\r\nUser-Agent: Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:0.9.7+) Gecko/20011220\r\nAccept: text/xml, application/xml,
application/xhtml+xml, text/html;q=0.9, "..., len=446, flags=0) at sslsecur.c:1100
#18 0x4362cacf in ssl_SecureWrite (ss=0x8765230, buf=0x8741388 "GET /tests.html
HTTP/1.1\r\nHost: pki.mcom.com\r\nUser-Agent: Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:0.9.7+) Gecko/20011220\r\nAccept: text/xml, application/xml,
application/xhtml+xml, text/html;q=0.9, "..., len=446) at sslsecur.c:1134
#19 0x436326d9 in ssl_Write (fd=0x8773188, buf=0x8741388, len=446) at sslsock.c:1252
#20 0x4356682a in nsSSLIOLayerWrite (fd=0x847a508, buf=0x8741388, amount=446) at
../../../../../mozilla/security/manager/ssl/src/nsNSSIOLayer.cpp:709
#21 0x4030e837 in PR_Write (fd=0x847a508, buf=0x8741388, amount=446) at
../../../../../mozilla/nsprpub/pr/src/io/priometh.c:141
#22 0x409347b5 in nsSocketOS::Write (this=0x8740d68, aBuf=0x8741388 "GET
/tests.html HTTP/1.1\r\nHost: pki.mcom.com\r\nUser-Agent: Mozilla/5.0 (X11; U;
Linux i686; en-US; rv:0.9.7+) Gecko/20011220\r\nAccept: text/xml,
application/xml, application/xhtml+xml, text/html;q=0.9, "..., aCount=446,
aBytesWritten=0x4103e938) at
../../../../mozilla/netwerk/base/src/nsSocketTransport.cpp:2458
#23 0x4093470e in nsSocketOS::WriteFromSegments (input=0x8741694,
closure=0x8740d68, fromSegment=0x8741388 "GET /tests.html HTTP/1.1\r\nHost:
pki.mcom.com\r\nUser-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+)
Gecko/20011220\r\nAccept: text/xml, application/xml, application/xhtml+xml,
text/html;q=0.9, "..., offset=0, count=446, countRead=0x4103e938) at
../../../../mozilla/netwerk/base/src/nsSocketTransport.cpp:2438
#24 0x40294a39 in ConstCharImpl::ReadSegments (this=0x8741690, writer=0x409346d8
<nsSocketOS::WriteFromSegments(nsIInputStream *, void *, char const *, unsigned
int, unsigned int, unsigned int *)>, closure=0x8740d68, aCount=446,
result=0x4103e938) at ../../../mozilla/xpcom/io/nsStringStream.cpp:359
#25 0x409348e7 in nsSocketOS::WriteFrom (this=0x8740d68, aIS=0x8741694,
aCount=16384, aBytesWritten=0x4103e938) at
../../../../mozilla/netwerk/base/src/nsSocketTransport.cpp:2484
#26 0x40975022 in nsHttpTransaction::OnDataWritable (this=0x8741030,
os=0x8740d68) at
../../../../../mozilla/netwerk/protocol/http/src/nsHttpTransaction.cpp:213
#27 0x4097416d in nsHttpConnection::OnDataWritable (this=0x87416c0,
request=0x8773158, context=0x87416c4, outputStream=0x8740d68, offset=0,
count=8192) at
../../../../../mozilla/netwerk/protocol/http/src/nsHttpConnection.cpp:669
#28 0x40935b0c in nsSocketWriteRequest::OnWrite (this=0x8773158) at
../../../../mozilla/netwerk/base/src/nsSocketTransport.cpp:2882
#29 0x40930820 in nsSocketTransport::doReadWrite (this=0x8740b60,
aSelectFlags=3) at ../../../../mozilla/netwerk/base/src/nsSocketTransport.cpp:1081
#30 0x4092f0fd in nsSocketTransport::Process (this=0x8740b60, aSelectFlags=3) at
../../../../mozilla/netwerk/base/src/nsSocketTransport.cpp:516
#31 0x40936e97 in nsSocketTransportService::Run (this=0x8146a38) at
../../../../mozilla/netwerk/base/src/nsSocketTransportService.cpp:516


I confirm no crash with that other page.

As you have filed another bug on the thrid issue, I'll resolve this bug as a
duplicate of 115683.


*** This bug has been marked as a duplicate of 115683 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

11 years ago
Version: psm2.2 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.