Closed Bug 1156888 Opened 6 years ago Closed 6 years ago

Eagerly scan LazyScripts

Categories

(Core :: JavaScript: GC, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: terrence, Assigned: terrence)

References

Details

Attachments

(1 file)

These are the 3rd most common marked thing, yet we currently go fully out-of-line to trace these. This adds eagerlyMarkChildren for LazyScript and move traceChildren adjacent. Eventually I'd like to share all the duplicate implementations, but for now let's just match the existing style.
Attachment #8595473 - Flags: review?(sphink)
Attachment #8595473 - Flags: review?(sphink) → review+
Duplicate of this bug: 1158310
https://hg.mozilla.org/mozilla-central/rev/1c0edbdb1936
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.