Composer colorpicker widget on toolbar doesn't show correct "text" attribute color on <body> element

VERIFIED FIXED in mozilla0.9.8

Status

SeaMonkey
Composer
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Charles Manske, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.8
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

16 years ago
1. Launch Composer
2. Use Format | Page Colors and Background dialog
3. Click on "Use Custom Colors" radio and change the "Normal Text" color to 
something other than black.
4. Change Background color as well.
5. Click Ok to apply color.
Any text in the page that is "default" (no <font color=.. used) and the 
background does change correctly in the page, but not on the toolbar swatches.

Two problems:
1. When caret is in the 'default' (normal) text, the color swatch in the toolbar
never shows the actual color set on the "text" attribute by the dialog.
2. The color swatch for the background does show correctly, but only after you
move the caret with arrow key or clicking somewhere.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.8
(Assignee)

Comment 1

16 years ago
Created attachment 62266 [details] [diff] [review]
Fix
(Assignee)

Updated

16 years ago
Keywords: patch, review
Whiteboard: FIX IN HAND, need r=,sr=
(Assignee)

Comment 2

16 years ago
Created attachment 62270 [details] [diff] [review]
Update: Trigger UI update only if color value changed
Attachment #62266 - Attachment is obsolete: true

Comment 3

16 years ago
Comment on attachment 62270 [details] [diff] [review]
Update: Trigger UI update only if color value changed

r=syd
Attachment #62270 - Flags: review+
(Assignee)

Updated

16 years ago
Whiteboard: FIX IN HAND, need r=,sr= → FIX IN HAND, need sr=
(Assignee)

Comment 4

16 years ago
*** Bug 100327 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

16 years ago
*** Bug 100408 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Comment on attachment 62270 [details] [diff] [review]
Update: Trigger UI update only if color value changed

sr=hewitt
Attachment #62270 - Flags: superreview+
(Assignee)

Comment 7

16 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: patch, review
Resolution: --- → FIXED
Whiteboard: FIX IN HAND, need sr=

Comment 8

16 years ago
Looks good to me on Win 2k using trunk build 2002010803.

Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.