Closed Bug 1156964 Opened 8 years ago Closed 8 years ago

orca reads window title on every tab in e10s

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
e10s + ---
firefox40 --- fixed

People

(Reporter: tbsaunde, Assigned: smaug)

References

Details

Attachments

(1 file)

If you enable e10s and use orca then every time you hit tab the window title gets read.  I believe this is because we send window activate / deactivate messages on every tab.  I believe that is caused by nsWindow::OnKeyPressEvent returning a different value than it does in non e10s.
Attached patch v1Splinter Review
Assignee: nobody → bugs
Attachment #8602149 - Flags: review?(tbsaunde+mozbugs)
Attachment #8602149 - Flags: review?(felipc)
Attachment #8602149 - Flags: review?(felipc) → review+
Attachment #8602149 - Flags: review?(tbsaunde+mozbugs) → feedback+
https://hg.mozilla.org/mozilla-central/rev/6e730c0cfe2d
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.