May Social Media Requests 3/4

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: M.J. Kelly, Assigned: mternoway)

Tracking

Details

Attachments

(16 attachments, 9 obsolete attachments)

742.20 KB, image/png
Details
716.41 KB, image/png
Details
715.09 KB, image/png
Details
715.71 KB, image/png
Details
709.44 KB, image/png
Details
718.43 KB, image/png
Details
718.46 KB, image/png
Details
713.28 KB, image/png
Details
1.13 MB, image/png
Details
1.13 MB, image/png
Details
1.13 MB, image/png
Details
1.12 MB, image/png
Details
1.13 MB, image/png
Details
1.14 MB, image/png
Details
1.13 MB, image/png
Details
1.17 MB, image/png
Details
(Reporter)

Description

3 years ago
>>Project/Request Title:
May Social Media Requests 3/4

>>Project Overview:
General social media graphics for Firefox on Facebook and Twitter in May.

    Bug 1 = content for May 1 - 9 + TBDs. All due by April 29.
    Bug 2 = content for May 10 - 16. All due by May 5 (M.J. on PTO, May 6-8.)
    Bug 3 = content for May 17 - 23. All due by May 13.
    Bug 4 = content for May 24 - 31. All due by May 20.

We'd like to include the publication date in the file names. Example:

graphic_facebook_2015-05-15
graphic_twitter_2015-05-15

>> Creative Help Needed:
Copy:    No 
Design:  Yes 
Video:   No 
Other:  No

>>Creative Specs:
Facebook (FB) 1200x627 px. Some graphics need to have <20% text to be boosted. 
Twitter (TW) graphics 1760x800 px. 

>>CTA and Design:
[10]	5/20/2015 GRAPHIC NEED to promote downloading Firefox via the social status, "You can have trusted, flexible or fast. If you want all there, that's a job for Firefox. [LINK] [GRAPHIC]"

THINKING: Venn diagram with Trusted Flexible and Fast in three circles, Firefox represented in the intersection. Hand drawn arrow pointing to the middle with a note: "Where the awesome happens." These items for the circles: https://docs.google.com/a/mozilla.com/document/d/1aDB_wDqCn4-Mf5y0UFGx0zw4MxTCq5SH7p0BLKvpScA/edit?usp=sharing

Would love your super creative ideas on this one so it gets shared a lot. Maybe it looks like it's drawn on a chalkboard? We plan to boost this one, so it needs to adhere to the >20% text rule. 



>>Expected Launch Date:
2015-05-14

>>Mozilla Goal:
All

>>Mozilla Creative Collective:
No

>>Points of Contact:
ehull@mozilla.com, mthayer@mozilla.com, pmjcreations@gmail.com, monica.ceballos@ogilvy.com, robert.santos@ogilvy.com, matthew.whatley@ogilvy.com,
(Reporter)

Comment 1

3 years ago
MT, text is our first choice for the diagram, but if it takes up too much space to fit the 20% rule, one thought is to use icons.

Updated

3 years ago
Assignee: jbalaco → mternoway
Status: NEW → ASSIGNED
Due Date: 2015-05-13
(Assignee)

Comment 2

3 years ago
Created attachment 8604860 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline.jpg

Hey MJ, I've played this one off of your suggestion to use a chalkboard. I thought it would appear lively if we made it look like it was on a canvas with paint. Let me know what you think of something like this. 

MT
(Reporter)

Comment 3

3 years ago
Hi MT, 

The layout looks really nice. 

For the content inside, we had the team come up with different things that make up each area of the diagram (https://docs.google.com/document/d/1aDB_wDqCn4-Mf5y0UFGx0zw4MxTCq5SH7p0BLKvpScA/edit), with Firefox capturing the middle. Here are a bunch: http://www.huffingtonpost.com/2009/11/06/funniest-venn-diagrams-th_n_347552.html. 

If "Where the awesome happens" doesn't fit, we can drop it.
(Assignee)

Comment 4

3 years ago
(In reply to M.J. Kelly from comment #3)
> Hi MT, 
> 
> The layout looks really nice. 
> 
> For the content inside, we had the team come up with different things that
> make up each area of the diagram
> (https://docs.google.com/document/d/1aDB_wDqCn4-
> Mf5y0UFGx0zw4MxTCq5SH7p0BLKvpScA/edit), with Firefox capturing the middle.
> Here are a bunch:
> http://www.huffingtonpost.com/2009/11/06/funniest-venn-diagrams-th_n_347552.
> html. 
> 
> If "Where the awesome happens" doesn't fit, we can drop it.

Thanks MJ. I like the analogies...is the intention to include both the word 'Fast' and 'Bullet Train' in one circle for example?
(Assignee)

Comment 5

3 years ago
Created attachment 8605897 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline.png

Hey MJ, let me know if this is what you had in mind!
Attachment #8604860 - Attachment is obsolete: true
(Reporter)

Comment 6

3 years ago
Oooo, we're getting there! Looks really good! Can you add smaller notes in the hand-drawn font for Flexible, Fast, Trusted? Sorry I missed your comment yesterday.
(Assignee)

Comment 7

3 years ago
Created attachment 8605900 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline.png

Thanks! How about keeping the supporting copy outside of the diagram like this.
Attachment #8605897 - Attachment is obsolete: true

Comment 8

3 years ago
(In reply to mternoway from comment #7)
> Created attachment 8605900 [details]
> firefox_venn-diagram_may-20-2015_facebook-timeline.png
> 
> Thanks! How about keeping the supporting copy outside of the diagram like
> this.

I absolutely love this! I think we should make it a poster or a T-shirt or something.

One thought, too: Do we have too many type styles going on? I like the "awesome" line in the handwriting, but the other callouts are a bit distracting.

I think we could try one of a couple of things:

Contain all the copy withing the circles in one of two ways:

Flexible:
Gumby

Gumby
(flexible)

Or leave Fast, Flexible, Trusted off altogether. I know that would be more work for anyone who saw it, but I also think it would be more rewarding. That would be my vote.
(Reporter)

Comment 9

3 years ago
I really love this. The issue is that it won't pass the 20% text rule. 

Options: 
1. We don't boost it, which means we won't trigger the 20% rule. Liz and Michaela, thoughts?

2. We convert the text into images. Crazy idea, but it could be funny. Or awful. Probably the latter, but I thought I'd throw it out there.

There are also some things listed for the middle areas of Fast/Flexible, Flexible/Trusted, Trusted/Fast. 

Also, if this goes on a T-shirt, I will have finally arrived. ;-)
Flags: needinfo?(mthayer)
Flags: needinfo?(ehull)

Comment 10

3 years ago
It's perfect. 20% be damned! I think we should try to run it under the promotion radar (maybe it'll pass). Otherwise, let's incorporate a "share this" CTA into the copy of the post to try to boost the audience organically. 

It's too beautiful to try and alter in any way just to suit FB's tyranny. We can always promote on Twitter, no problem!
Flags: needinfo?(ehull)
(Reporter)

Comment 11

3 years ago
Awesome, we're good on this. The other languages are in the doc.
Flags: needinfo?(mthayer)
(Assignee)

Comment 12

3 years ago
Created attachment 8607216 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline.png

Thanks all! If we are not going the 20% rule route. I've tweaked the graphic to include the in-between section copy. Let me know if you want to go ahead with this look. If so, I can start creating the localized versions. 

MT
Attachment #8605900 - Attachment is obsolete: true
(Reporter)

Comment 13

3 years ago
Yeah! Love it with the added copy.
(Assignee)

Comment 14

3 years ago
Great, one more thing, I am not seeing translations for 'Where the awesome happens' are we ok leaving this in English for all?
(Reporter)

Comment 15

3 years ago
Bummed that I missed it, but yes, let's leave it out for the other locales.
(Assignee)

Comment 16

3 years ago
Created attachment 8607649 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_de.png
(Assignee)

Comment 17

3 years ago
Created attachment 8607650 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_es.png
(Assignee)

Comment 18

3 years ago
Created attachment 8607651 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_fr.png
(Assignee)

Comment 19

3 years ago
Created attachment 8607652 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_gr.png
(Assignee)

Comment 20

3 years ago
Created attachment 8607653 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_id.png
(Assignee)

Comment 21

3 years ago
Created attachment 8607655 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_pt.png
(Reporter)

Comment 22

3 years ago
Sorry, MT! I meant let's leave it off for the other locales rather than in English.
(Assignee)

Comment 23

3 years ago
Created attachment 8607667 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_de.png

my mistake!
Attachment #8607649 - Attachment is obsolete: true
(Assignee)

Comment 24

3 years ago
Created attachment 8607669 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_es.png
Attachment #8607650 - Attachment is obsolete: true
(Assignee)

Comment 25

3 years ago
Created attachment 8607670 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_fr.png
Attachment #8607651 - Attachment is obsolete: true
(Assignee)

Comment 26

3 years ago
Created attachment 8607671 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_gr.png
Attachment #8607652 - Attachment is obsolete: true
(Assignee)

Comment 27

3 years ago
Created attachment 8607672 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_id.png
Attachment #8607653 - Attachment is obsolete: true
(Assignee)

Comment 28

3 years ago
Created attachment 8607673 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_pl.png
(Assignee)

Comment 29

3 years ago
Created attachment 8607674 [details]
firefox_venn-diagram_may-20-2015_facebook-timeline_pt.png
Attachment #8607655 - Attachment is obsolete: true
(Assignee)

Comment 30

3 years ago
Created attachment 8608210 [details]
firefox_venn-diagram_may-20-2015_twitter-timeline_de.png
(Assignee)

Comment 31

3 years ago
Created attachment 8608211 [details]
firefox_venn-diagram_may-20-2015_twitter-timeline_es.png
(Assignee)

Comment 32

3 years ago
Created attachment 8608213 [details]
firefox_venn-diagram_may-20-2015_twitter-timeline_fr.png
(Assignee)

Comment 33

3 years ago
Created attachment 8608214 [details]
firefox_venn-diagram_may-20-2015_twitter-timeline_gr.png
(Assignee)

Comment 34

3 years ago
Created attachment 8608215 [details]
firefox_venn-diagram_may-20-2015_twitter-timeline_id.png
(Assignee)

Comment 35

3 years ago
Created attachment 8608216 [details]
firefox_venn-diagram_may-20-2015_twitter-timeline_pl.png
(Assignee)

Comment 36

3 years ago
Created attachment 8608217 [details]
firefox_venn-diagram_may-20-2015_twitter-timeline_pt.png
(Assignee)

Comment 37

3 years ago
Created attachment 8608219 [details]
firefox_venn-diagram_may-20-2015_twitter-timeline.png

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.