Expanding window cause unwanted scrollbar when using flexible box with APZ

RESOLVED DUPLICATE of bug 1157579

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1157579
3 years ago
3 years ago

People

(Reporter: xidorn, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

(Reporter)

Description

3 years ago
Step to reproduce:
1. Open an e10s window
2. Open data:text/html,<body%20style="display:flex;width:100%;height:100%;margin:0">
3. Slowly enlarge the window, or just press F11 enter fullscreen mode

This issue shows on Windows, but I cannot reproduce it on Linux.
(Reporter)

Updated

3 years ago
tracking-e10s: --- → ?
(Reporter)

Comment 1

3 years ago
Sometimes it could be really annoying that, the horizontal and vertical scrollbars keep appearing alternately infinitely.
(Reporter)

Updated

3 years ago
Summary: [e10s] Expanding windows cause unwanted scrollbar when using flexible box → [e10s] Expanding window cause unwanted scrollbar when using flexible box
Can you get the scrollbar to stick around, or does it just briefly flash & disappear?

(I can't repro on Linux or Win 8.1, FWIW.)
(Reporter)

Comment 3

3 years ago
It seems to be a bug related to APZ instead of e10s.

I cannot reproduce this problem today when I open Nightly. Later I realize that it is probably related to APZ which was enabled for one day yesterday.

This problem can be easily reproduced just in about:home, where the issue is far more annoying than the test page I put in comment 0.
Blocks: 1154825
tracking-e10s: ? → ---
(Reporter)

Comment 4

3 years ago
FYI, to enable APZ, you need to switch on layers.async-pan-zoom.enabled in about:config, and restart Firefox.
(Reporter)

Updated

3 years ago
Summary: [e10s] Expanding window cause unwanted scrollbar when using flexible box → Expanding window cause unwanted scrollbar when using flexible box with APZ
(Reporter)

Updated

3 years ago
Blocks: 1154459
No longer blocks: 1154825
This appears to be the same issue as bug 1157579. I can repro on Linux with APZ enabled and the patch I have for that bug seems to fix it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157579
You need to log in before you can comment on or make changes to this bug.